View Issue Details

IDProjectCategoryView StatusLast Update
0024494mantisbtfilterspublic2018-06-22 02:40
Reportergrisch111Assigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version2.4.0 
Target VersionFixed in Version 
Summary0024494: Tags Field visible for every Project in View Issues Page
Description

Hi,
I am using Mantis 2.4.0. For every Project i can filter for the Tags Field on the view Issues page for every project even if the tags field is not activated in this project. It would be nice if you could implement the search field for tags only for projects using this field and disable it for the other projects.

Thank you.
Regards

Steps To Reproduce

Klick on "View Issues"

TagsNo tags attached.

Activities

atrol

atrol

2018-05-29 07:30

developer   ~0059967

Last edited: 2018-05-29 07:44

View 2 revisions

Are you talking about the functionality of the plugin FilterPageEdit or the standard functionality of the Mantis core on View Issues page?

grisch111

grisch111

2018-05-29 07:35

reporter   ~0059969

Sorry, wrong project... this is a Core Mantisbt Issue. Could you please move this ticket, thank you.

atrol

atrol

2018-05-29 07:46

developer   ~0059971

I wasn't able to reproduce the issue using the given information and using latest stable version (2.14.0 at the moment) .

We changed quite a lot since 2.4.0 in this area.
Are you able to reproduce the issue in 2.14.0?

grisch111

grisch111

2018-06-07 04:26

reporter   ~0060028

Thanks for your answer, yes, I can reproduce that in Mantis 2.14.0 I have not activated the "Tags" in this project and I still see the filter "tags" . I can also attach tags to several tickets by choosing "attach tags" from the list, which I think should not be possible, because I do not have activated the "tags" for this project.



tags1.PNG (1,406 bytes)
tags1.PNG (1,406 bytes)
tags2.PNG (2,757 bytes)
tags2.PNG (2,757 bytes)
atrol

atrol

2018-06-07 04:32

developer   ~0060030

I have not activated the "Tags" in this project

How did you activate tags for other projects?

grisch111

grisch111

2018-06-07 04:38

reporter   ~0060032

manage < manage configuration < Configuration Report and then use it for eg bug_report_page fields or bug_update_page_fields
is this not an activation?

grisch111

grisch111

2018-06-07 04:41

reporter   ~0060033

like this



tags3.PNG (7,359 bytes)
tags3.PNG (7,359 bytes)
atrol

atrol

2018-06-07 04:47

developer   ~0060034

Unfortunately your screen shot is missing the column Project Name.
Is it All Projects or the name of a project?

grisch111

grisch111

2018-06-07 04:48

reporter   ~0060035

Name of one project only and for All Users

atrol

atrol

2018-06-07 04:54

developer   ~0060036

The default setting is

$g_bug_report_page_fields = array(
    'additional_info',
    'attachments',
    'category_id',
    'due_date',
    'handler',
    'os',
    'os_version',
    'platform',
    'priority',
    'product_build',
    'product_version',
    'reproducibility',
    'severity',
    'steps_to_reproduce',
    'tags',
    'target_version',
    'view_state',
);

So any other project will use this default setting where tags is included.

You can change the default setting by adding an entry to config_inc.php, something like

$g_bug_report_page_fields = array(
    'additional_info',
    'attachments',
    'category_id',
    'due_date',
    'handler',
    'os',
    'os_version',
    'platform',
    'priority',
    'product_build',
    'product_version',
    'reproducibility',
    'severity',
    'steps_to_reproduce',
    'target_version',
    'view_state',
);

or you can change it on the config page by creating an entry for All Projects

atrol

atrol

2018-06-07 04:59

developer   ~0060037

Last edited: 2018-06-07 05:01

View 2 revisions

As a side note, I use tag_view_threshold and tag_attach_thresholdand set them to 100 (= NOBODY) if I want completely supress tags.

This might also be the better way for you, as it seems you want to hide tags also on filter page.

grisch111

grisch111

2018-06-07 05:37

reporter   ~0060038

My default setting in config_inc.php is:

$g_bug_report_page_fields = array (
0 => 'category_id',
2 => 'handler',
3 => 'priority',
4 => 'severity',
5 => 'target_version',
12 => 'summary',
13 => 'description',
16 => 'attachments',
);

so only one project should have the tags field since I entered it under manage < manage configuration < Configuration Report and then use it for eg bug_report_page fields

I have no entry for All Projects unter manage < manage configuration < Configuration Report and then use it for eg bug_report_page fields. As far as I know the default settings from the config_inc.php will be used right, or do I need to copy my bug_report_page fields in there?



tags4.PNG (26,593 bytes)
tags4.PNG (26,593 bytes)
atrol

atrol

2018-06-07 05:48

developer   ~0060039

Your config_inc.php should be

$g_bug_report_page_fields = array(
    'category_id',
    'handler',
    'priority',
    'severity',
    'target_version',
    'summary',
    'description',
    'attachments',
);
grisch111

grisch111

2018-06-07 07:05

reporter   ~0060040

"As a side note, I use tag_view_threshold and tag_attach_thresholdand set them to 100 (= NOBODY) if I want completely supress tags.
This might also be the better way for you, as it seems you want to hide tags also on filter page."

I tried this solution. As far as I can see it is working on project level so I can use this. Thank you.

atrol

atrol

2018-06-07 07:18

developer   ~0060041

grisch111,

This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

Issue History

Date Modified Username Field Change
2018-05-29 07:14 grisch111 New Issue
2018-05-29 07:30 atrol Status new => feedback
2018-05-29 07:30 atrol Note Added: 0059967
2018-05-29 07:35 grisch111 Note Added: 0059969
2018-05-29 07:35 grisch111 Status feedback => new
2018-05-29 07:43 atrol Project Plugin - FilterPageEdit => mantisbt
2018-05-29 07:43 atrol Category General => filters
2018-05-29 07:43 atrol Product Version => 2.4.0
2018-05-29 07:44 atrol Note Edited: 0059967 View Revisions
2018-05-29 07:46 atrol Status new => feedback
2018-05-29 07:46 atrol Note Added: 0059971
2018-06-07 04:26 grisch111 File Added: tags1.PNG
2018-06-07 04:26 grisch111 File Added: tags2.PNG
2018-06-07 04:26 grisch111 Note Added: 0060028
2018-06-07 04:26 grisch111 Status feedback => new
2018-06-07 04:32 atrol Status new => feedback
2018-06-07 04:32 atrol Note Added: 0060030
2018-06-07 04:38 grisch111 Note Added: 0060032
2018-06-07 04:38 grisch111 Status feedback => new
2018-06-07 04:41 grisch111 File Added: tags3.PNG
2018-06-07 04:41 grisch111 Note Added: 0060033
2018-06-07 04:47 atrol Status new => feedback
2018-06-07 04:47 atrol Note Added: 0060034
2018-06-07 04:48 grisch111 Note Added: 0060035
2018-06-07 04:48 grisch111 Status feedback => new
2018-06-07 04:54 atrol Status new => feedback
2018-06-07 04:54 atrol Note Added: 0060036
2018-06-07 04:59 atrol Note Added: 0060037
2018-06-07 05:01 atrol Note Edited: 0060037 View Revisions
2018-06-07 05:37 grisch111 File Added: tags4.PNG
2018-06-07 05:37 grisch111 Note Added: 0060038
2018-06-07 05:37 grisch111 Status feedback => new
2018-06-07 05:48 atrol Status new => feedback
2018-06-07 05:48 atrol Note Added: 0060039
2018-06-07 07:05 grisch111 Note Added: 0060040
2018-06-07 07:05 grisch111 Status feedback => new
2018-06-07 07:17 atrol Assigned To => atrol
2018-06-07 07:17 atrol Status new => resolved
2018-06-07 07:17 atrol Resolution open => no change required
2018-06-07 07:18 atrol Note Added: 0060041
2018-06-22 02:40 atrol Status resolved => closed