View Issue Details

IDProjectCategoryView StatusLast Update
0024501mantisbtinstallationpublic2018-06-20 10:57
ReporterfmanAssigned Toatrol 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version2.16.0Fixed in Version2.16.0 
Summary0024501: MantisBT on Windows - Check for php_fileinfo.dll enabled on php.ini
Description

I've a MantisBT with plugins working OK on MAMP Mac OS, then install WAMP Bitnami stack and issues loading files via plugin_file.php?file= started.
After debugging I've found the issue => finfo() was crashing.

I've found following note in php.net

<i>
I am running Windows 7 with Apache. It took hours to figure out why it was not working.
First, enable the php_fileinfo.dll extension in you php.ini. You'll also need the four magic files that are found in the following library:
http://sourceforge.net/projects/gnuwin32/files/file/4.23/file-4.23-bin.zip/download
An environment variable or a direct path to the file named "magic" is necessary, without any extension.
Then, make sure that xdebug is either turned off or set the ini error_reporting to not display notices or warnings for the script.
Hope this saves someone a few hours of frustration!
</i>

Applying the 'enable the php_fileinfo.dll extension in you php.ini', solved my issue.

Then request is to add if possible check for the needed extension.

regards

TagsNo tags attached.

Relationships

related to 0024128 closedatrol Unable to start system check or installation with wrong PHP version 

Activities

atrol

atrol

2018-05-30 05:01

developer   ~0059975

Fileinfo is documented as a required extension if you are using file attachments ($g_allow_file_upload = ON;)
https://mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.install.requirements.software

Furthermore you are told to run admin/check/index.php after installation or upgrade.
There you will get an error if attachmens are enabled ($g_allow_file_upload = ON;) and Fileinfo extension is not enabled.

Do you agree we can resolve this as No change required

atrol

atrol

2018-06-09 09:09

developer   ~0060050

fman,

You did not provide any feedback; I am therefore resolving this issue as "no change required".

Feel free to reopen the issue at a later time if you don't agree that the issue can be set to resolved.

fman

fman

2018-06-09 11:49

reporter   ~0060052

I'm sorry for missing feedback.
Answers you have provided on https://www.mantisbt.org/bugs/view.php?id=24501#c59975, seems good, but IMHO problem is that you can face this issue if you have upload disabled (Ok it seems a weird thing to do), but because you are using plugins.

Really I do not remember to have got a warning after installing, then my suggestion is just to add the check always during installation no matter you have enabled file upload.

Thanks a lot for your help.

atrol

atrol

2018-06-09 16:21

developer   ~0060053

just to add the check always during installation no matter you have enabled file upload.

Added a warning for it

PR https://github.com/mantisbt/mantisbt/pull/1360

fman

fman

2018-06-20 10:57

reporter   ~0060124

Thanks a lot

Related Changesets

MantisBT: master 963c06fe

2018-06-09 16:00:38

atrol

Details Diff
Enhance PHP fileinfo extension checking

Add a warning check for fileinfo extension if file uploads are disabled.

This is useful as a lot of plugins use function plugin_file()
which leads to a call of file_create_finfo() where the fileinfo
extension is needed.

Fixes 0024501
Affected Issues
0024501
mod - admin/check/check_attachments_inc.php Diff File
mod - admin/check/check_php_inc.php Diff File
mod - docbook/Admin_Guide/en-US/Installation.xml Diff File

Issue History

Date Modified Username Field Change
2018-05-30 04:36 fman New Issue
2018-05-30 05:01 atrol Status new => feedback
2018-05-30 05:01 atrol Note Added: 0059975
2018-06-09 09:09 atrol Assigned To => atrol
2018-06-09 09:09 atrol Status feedback => resolved
2018-06-09 09:09 atrol Resolution open => no change required
2018-06-09 09:09 atrol Note Added: 0060050
2018-06-09 11:49 fman Note Added: 0060052
2018-06-09 16:21 atrol Note Added: 0060053
2018-06-09 16:21 atrol Status resolved => assigned
2018-06-09 16:21 atrol Target Version => 2.16.0
2018-06-09 16:26 atrol Relationship added related to 0024128
2018-06-20 05:53 atrol Changeset attached => MantisBT master 963c06fe
2018-06-20 05:53 atrol Status assigned => resolved
2018-06-20 05:53 atrol Resolution no change required => fixed
2018-06-20 05:53 atrol Fixed in Version => 2.16.0
2018-06-20 10:57 fman Note Added: 0060124