View Issue Details

IDProjectCategoryView StatusLast Update
0024514mantisbtuipublic2018-06-06 00:39
ReporterSL-Gundam Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version2.14.0 
Summary0024514: duedate broken
Description

The date format is not consistent. This is causing an issue with updating an existing duedate

Steps To Reproduce
  1. I have a new ticket with an empty duedate
  2. I edit the issue and use the date selector to pick a date for the duedate field
  3. The resulting date shown is: 2018-06-12 03:39
  4. Save the issue
  5. The duedate shown is now: 12-06-2018 03:39
  6. Edit the issue again
  7. For split second it will show the date from 5. before changing it to: 12-06-20 03:39 (losing the numbers of the year)
  8. Save the issue
  9. The duedate shown is now: 20-06-2012 03:39
TagsNo tags attached.

Relationships

duplicate of 0023701 new different or localized datetime formats delete due_date on updates 

Activities

atrol

atrol

2018-06-01 01:25

developer   ~0059995

How did you set $g_normal_date_format and $g_datetime_picker_format ?

Did you consider the note and the warning at https://www.mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.config.date ?

SL-Gundam

SL-Gundam

2018-06-01 12:41

reporter   ~0060004

Last edited: 2018-06-01 12:42

View 2 revisions

hmmm

$g_short_date_format    = 'd-m-Y';
$g_normal_date_format   = 'd-m-Y H:i';
$g_complete_date_format = 'd-m-Y H:i T';

$g_datetime_picker_format does not exist
Keep in mind, i configured these way back when in 2007. Did not even know that they could be configured... It's just that long ago
Might have been interesting to implement a check in the install.php on upgrades for users where this differs from the default...

But case closed as far as i'm concerned. Thanks

Issue History

Date Modified Username Field Change
2018-05-31 21:45 SL-Gundam New Issue
2018-06-01 01:25 atrol Status new => feedback
2018-06-01 01:25 atrol Note Added: 0059995
2018-06-01 12:41 SL-Gundam Note Added: 0060004
2018-06-01 12:41 SL-Gundam Status feedback => new
2018-06-01 12:42 SL-Gundam Note Edited: 0060004 View Revisions
2018-06-01 15:49 atrol Assigned To => atrol
2018-06-01 15:49 atrol Status new => resolved
2018-06-01 15:49 atrol Resolution open => duplicate
2018-06-01 15:49 atrol Relationship added duplicate of 0023701
2018-06-06 00:39 vboctor Status resolved => closed