View Issue Details

IDProjectCategoryView StatusLast Update
0024633mantisbtbugtrackerpublic2018-09-04 01:23
ReporteratrolAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version2.17.0Fixed in Version2.17.0 
Summary0024633: Late error message when trying to resolve issues
Description

When resolving an issue, we display an error message after a user might have entered some data,
e.g. he set Resolution, set Fixed in Version and added a note.
After clicking Resolve Issue he gets APPLICATION ERROR # 1104 This issue cannot be resolved until all dependant issues have been resolved.

We should throw the error as early as possible to avoid unneeded entering of data.

TagsNo tags attached.

Relationships

related to 0024616 closedatrol relationship visibility in different project permission 

Activities

Related Changesets

MantisBT: master 1a2cc74d

2018-07-22 07:30:17

atrol

Details Diff
Enhance error handling when resolving/closing issues

Trigger error at an early state if user is not allowed to resolve/close
issues due to unresolved child issues.

Issue 0024633
Affected Issues
0024633
mod - bug_change_status_page.php Diff File

Issue History

Date Modified Username Field Change
2018-07-25 17:17 atrol New Issue
2018-07-25 17:17 atrol Status new => assigned
2018-07-25 17:17 atrol Assigned To => atrol
2018-07-25 17:21 atrol Note Added: 0060323
2018-07-25 17:22 atrol Description Updated View Revisions
2018-07-25 17:28 atrol Relationship added related to 0024616
2018-07-30 05:32 atrol Target Version 2.16.0 => 2.17.0
2018-07-31 05:54 atrol Changeset attached => MantisBT master 1a2cc74d
2018-07-31 06:13 atrol Status assigned => resolved
2018-07-31 06:13 atrol Resolution open => fixed
2018-07-31 06:13 atrol Fixed in Version => 2.17.0
2018-09-04 01:23 vboctor Status resolved => closed