View Issue Details

IDProjectCategoryView StatusLast Update
0024831mantisbtuipublic2018-10-09 19:14
ReporterJohanLiAssigned Todregad 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionno change required 
PlatformBitnami on AzureOSUbuntuOS Version16.04.3
Product Version2.17.1 
Target VersionFixed in Version 
Summary0024831: Unable to create private note
Description

When I try to create a private note I get the following error:

APPLICATION ERROR 0000029

Invalid value for 'files'

Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.

If I create a note first and then make it private it works as intended.

Bitnami support asked me to upgrade to the latest version which I did but that did not help.

Steps To Reproduce

Create new note in any project and check the private box. Error shows upon pressing submit

Additional Information

Keywords: Mantis - Microsoft Azure - Technical issue - Permissions
Description:
MantisBT Version 2.15.0
PHP Version 7.0.27
MantisBT Database Information
Schema Version 209
ADOdb Version 5.20.12

When I try to create a private note I get the following error:

APPLICATION ERROR 0000029

Invalid value for 'files'

Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.

And the trace:

Detailed error information
Full path: /opt/bitnami/apps/mantis/htdocs/core/error_api.php
Line number: 85
Stack trace

Filename Line Class Type Function Args
0 /opt/bitnami/apps/mantis/htdocs/core/commands/Command.php 136 IssueNoteAddCommand -> validate -
1 /opt/bitnami/apps/mantis/htdocs/bugnote_add.php 77 Command -> execute -

TagsNo tags attached.

Relationships

related to 0009802 acknowledged Private attachments 

Activities

JohanLi

JohanLi

2018-10-09 05:12

reporter  

mantis.png (16,862 bytes)
mantis.png (16,862 bytes)
dregad

dregad

2018-10-09 06:17

developer   ~0060759

Attachements are not supported for private notes to avoid any confusion, because even though the note itself can be private, the attachment itself always remains public (see 0009802). You should normally not be seeing the "Upload files" section if private is checked - is Javascript disabled ?

JohanLi

JohanLi

2018-10-09 07:53

reporter   ~0060760

Hmm that's interesting. So if I check the private box the upload files box should disappear?

That would at least explain why the error mentions files.

Javascript is not disabled on any of the browsers I have tested on.

JohanLi

JohanLi

2018-10-09 07:56

reporter   ~0060761

Ok this is strange. It does work in IE 11, not in chrome, FF or Edge.

I've got uBlock Origin installed (but disabled for the mantis domain) on chrome and FF.

atrol

atrol

2018-10-09 08:03

developer   ~0060762

Last edited: 2018-10-09 08:04

View 2 revisions

So if I check the private box the upload files box should disappear?

Right.
Does the box disappear if you try to add a private note on 0024831 ?
If so, there is a problem with your server installation.
If not, there is a problem with your browser.

JohanLi

JohanLi

2018-10-09 08:22

reporter   ~0060763

Yes, it works fine here.

I now see that I have a bunch of console errors regarding Content Security Policy directives so it's something on the server that needs fixing:

Refused to execute inline script because it violates the following Content Security Policy directive: "script-src 'self'". Either the 'unsafe-inline' keyword, a hash ('sha256-ZvwxMq+CTzyDnl1PToT3SDr+oZUrDYI3qxpeXo7+rro='), or a nonce ('nonce-...') is required to enable inline execution.

JohanLi

JohanLi

2018-10-09 09:46

reporter   ~0060764

Installed a certificate and everything started working.

dregad

dregad

2018-10-09 19:14

developer   ~0060767

Thanks for the feedback, good to hear you fixed the problem.

Issue History

Date Modified Username Field Change
2018-10-09 05:12 JohanLi New Issue
2018-10-09 05:12 JohanLi File Added: mantis.png
2018-10-09 06:17 dregad Note Added: 0060759
2018-10-09 06:17 dregad Relationship added related to 0009802
2018-10-09 07:23 atrol Status new => feedback
2018-10-09 07:23 atrol Description Updated View Revisions
2018-10-09 07:23 atrol Additional Information Updated View Revisions
2018-10-09 07:53 JohanLi Note Added: 0060760
2018-10-09 07:53 JohanLi Status feedback => new
2018-10-09 07:56 JohanLi Note Added: 0060761
2018-10-09 08:03 atrol Status new => feedback
2018-10-09 08:03 atrol Note Added: 0060762
2018-10-09 08:04 atrol Note Edited: 0060762 View Revisions
2018-10-09 08:22 JohanLi Note Added: 0060763
2018-10-09 08:22 JohanLi Status feedback => new
2018-10-09 09:46 JohanLi Note Added: 0060764
2018-10-09 19:14 dregad Assigned To => dregad
2018-10-09 19:14 dregad Status new => resolved
2018-10-09 19:14 dregad Resolution open => no change required
2018-10-09 19:14 dregad Note Added: 0060767