View Issue Details

IDProjectCategoryView StatusLast Update
0024857mantisbtbugtrackerpublic2018-11-07 02:51
ReporterSubhashiniAssigned Toatrol 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version2.17.1 
Target VersionFixed in Version 
Summary0024857: "Product Version" field Missing for access level "Developer"
Description

Hi,

I installed the latest version 2.17.1 and created versions for projects (product version)
That meant features like change log and roadmap did not work etc.

1.Using manage projects - created a Private project
2.Clicking on Edit and added versions to the project
3.Reported an issue in reporter login (Refer 1st screenshot), While reporting the issue, i could select product version and lock the bug.
4.I have access level "developer", once developer tries to change status like "acknowledge/.............. / Resolved", product version field is missing.
FYI - I have changed this behavior by changing setting $g_show_product_version from AUTO to ON

Information which may useful to solve my query
1.Have not modified any source code
PHP version - 7.2.10
Database - My SQL 5.0.51
Web server - Apache
Browser - Firefox, IE, Chrome
Operating System - Windows 7

Is this a known issue that will be fixed in the next release? or have i done something wrong?
Try to give a solution, i tried with so many solutions but no luck

Additional Information

Refer screenshots

TagsNo tags attached.

Relationships

duplicate of 0024856 closedatrol Visibilty of projects in developer login 

Activities

Subhashini

Subhashini

2018-10-16 05:28

reporter  

developer login.png (32,213 bytes)
developer login.png (32,213 bytes)
reporter login.png (27,975 bytes)
reporter login.png (27,975 bytes)
atrol

atrol

2018-10-16 06:12

developer   ~0060816

There is nothing more to tell than what I told in 0024856.

This is a configuration issue that can't be reproduced using the given information.

FYI - I have changed this behavior by changing setting $g_show_product_version from AUTO to ON

You didn't provide detailed information for this step.
I assume there is something wrong with it.
Maybe you have set

$g_show_product_version = 'ON';

instead of setting it

$g_show_product_version = ON;

Subhashini,

This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system). I am therefore resolving this issue as duplicate of 0024856.

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

Subhashini

Subhashini

2018-10-16 06:17

reporter   ~0060817

I have set behaviour as
$g_show_product_version = ON;

I couldnt understand what details you are expecting from my side, let me know what you need. I will provide it..
I have tried with more solutions, spent totally 7hrs to fix this, but i couldnt.

Correct me where i am wrong

atrol

atrol

2018-10-16 07:22

developer   ~0060819

Providing detailed step by step instructions means to write something like:

  • Create a fresh install of Mantis 2.17.1
  • Add the following content to file config_inc.php in folder config
  • Click on button Button xyz
  • Select value ABC from List 1
  • Enter value 1.0 in field Field 1
  • ...
Subhashini

Subhashini

2018-10-16 08:54

reporter   ~0060820

Created a fresh install of Mantis 2.17.1
Added the following content to file config_inc.php in folder config
$g_show_product_version = ON;

Click on Manage projects -> Projects - > Click on create new project button
[My case: Entered Project name "Sample pro", status "development , Inherit Global categories "checked", View status as "Private"] and click on add project button

Once added - click on edit poject - under versions - Enter version name [my case: V1.1] and click on Add version button

Login access level "Reporter" - Click on Report Issue - Enter issues [Category, Reproducibility,Severity, Priority,Product Version, Assigned to, Summary, Description] and click on Submit issue

Login access level "Developer" - Click on Issue id - Once page opens (refer screenshot) - click on "change status to"
and "change status" to Confirmed / Acknowledged / Resolved] - Refer Screenshot [developer change status]

My query is - Product version is not displaying. Correct me where i am wrong in configuration settings or in others

I spend hardly 7hours to resolve this but no luck. Kindly guide me



atrol

atrol

2018-10-16 09:15

developer   ~0060822

Login access level "Reporter"

When following your instructions, there is no other user than the administrator.
You missed to describe some steps.

Even when assuming you created a user with access level reporter and assigned it to the privat project with the same access level, the description of next step can hardly be true.

Click on Report Issue - Enter issues [Category, Reproducibility,Severity, Priority,Product Version, Assigned to, Summary, Description] and click on Submit issue

Reporters don't get the field Assigned to with default settings and reporters are not able to choose a Product Version when followong your steps as they get no unreleased versions in the list.

Subhashini

Subhashini

2018-10-17 02:15

reporter   ~0060825

Ok, let me explain more in detail

Created a fresh install of Mantis 2.17.1
set behavior in config_inc.php
$g_show_product_version = ON;

Click on Manage projects -> Projects - > Click on create new project button
[My case: Entered Project name "Sample pro", status "development , Inherit Global categories "checked", View status as "Public"] and click on add project button

Click on Manage projects -> Projects - > Click on create new project button
[My case: Entered Project name " Test Project ", status "development , Inherit Global categories "checked", View status as "Private"] and click on add project button

Once added - click on edit project "Test Project "- under versions - Enter version name [my case: V1.1] and click on Add version button
After click on Add user and assign access level "reporter" to reporters
assign access level "developers" to developers
assign access level "Viewer" to Viewers

Login access level "Reporter" - Click on Report Issue - Enter issues [Category, Reproducibility,Severity, Priority,Product Version, Summary, Description] and click on Submit issue
Note: Product version displayed in reporter login for "reporter" access level

Login access level "Developer" - Click on Issue id - Once page opens (refer screenshot) - click on "change status to"
and "change status" to Confirmed / Acknowledged / Resolved] - Refer Screenshot attached previously [developer change status]
Here version is not displaying

My query is - Product version is not displaying only for private projects. Correct me where i am wrong in configuration settings or in others
Note:for public projects, product is showing for both access level " reporter" and "developer "

I hope provided necessary information, if needed any info let me know.

atrol

atrol

2018-10-17 08:16

developer   ~0060826

After click on Add user and assign access level "reporter" to reporters

Still the same what I wrote before:
When following your instructions, there is no other user than the administrator.
You missed to describe some steps.

And still the same, when following your steps

  • reporters don't get the field Assigned to
  • reporters get the Product Version field, but they are not able to choose a Product Version as they get no unreleased versions in the list.
atrol

atrol

2018-10-28 05:39

developer   ~0060863

Subhashini,

You did not provide feedback; I am therefore resolving this issue as "no change required".

Feel free to reopen the issue at a later time and provide more information to reproduce the issue.

Issue History

Date Modified Username Field Change
2018-10-16 05:28 Subhashini New Issue
2018-10-16 05:28 Subhashini File Added: developer login.png
2018-10-16 05:28 Subhashini File Added: reporter login.png
2018-10-16 06:12 atrol Assigned To => atrol
2018-10-16 06:12 atrol Status new => resolved
2018-10-16 06:12 atrol Resolution open => duplicate
2018-10-16 06:12 atrol Note Added: 0060816
2018-10-16 06:12 atrol Relationship added duplicate of 0024856
2018-10-16 06:17 Subhashini Note Added: 0060817
2018-10-16 06:17 Subhashini Status resolved => feedback
2018-10-16 06:17 Subhashini Resolution duplicate => reopened
2018-10-16 07:22 atrol Note Added: 0060819
2018-10-16 08:54 Subhashini File Added: developer login - view issue.png
2018-10-16 08:54 Subhashini File Added: developer change status.png
2018-10-16 08:54 Subhashini Note Added: 0060820
2018-10-16 08:54 Subhashini Status feedback => assigned
2018-10-16 09:15 atrol Assigned To atrol =>
2018-10-16 09:15 atrol Status assigned => feedback
2018-10-16 09:15 atrol Note Added: 0060822
2018-10-17 02:15 Subhashini Note Added: 0060825
2018-10-17 02:15 Subhashini Status feedback => new
2018-10-17 08:16 atrol Status new => feedback
2018-10-17 08:16 atrol Note Added: 0060826
2018-10-28 05:39 atrol Assigned To => atrol
2018-10-28 05:39 atrol Status feedback => resolved
2018-10-28 05:39 atrol Resolution reopened => no change required
2018-10-28 05:39 atrol Note Added: 0060863
2018-11-07 02:51 atrol Status resolved => closed