View Issue Details

IDProjectCategoryView StatusLast Update
0024896mantisbtauthenticationpublic2018-11-01 12:58
ReportercproensaAssigned Tocproensa 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.18.1 
Target Version2.19.0Fixed in Version2.19.0 
Summary0024896: Password managers don't work with password login page
Description

Since the username is not displayed in the new login form for password entry, the usual browsers password managers don't work properly, as it cannot associate passwords for different users.

TagsNo tags attached.

Relationships

related to 0023691 new New login UI is needlessly more complex and prevents use of password managers 

Activities

cproensa

cproensa

2018-10-25 19:53

developer   ~0060857

Setting a separate issue from 0023691, to manage this individually

cproensa

cproensa

2018-10-25 19:55

developer   ~0060858

PR https://github.com/mantisbt/mantisbt/pull/1402

Related Changesets

MantisBT: master 0041c91e

2018-11-01 12:52:27

cproensa


Committer: dregad Details Diff
Enable password managers to detect usernames

Make the username field a locked, non-visible field, instead of type
"hidden" input. This way the password managers present in browsers can
detect the different username values and remember them separately.
The problem is that inputs with type="hidden" are ignored by these
agents.

Fixes: 0024896
Affected Issues
0024896
mod - login_password_page.php Diff File

Issue History

Date Modified Username Field Change
2018-10-25 19:47 cproensa New Issue
2018-10-25 19:47 cproensa Relationship added related to 0023691
2018-10-25 19:53 cproensa Note Added: 0060857
2018-10-25 19:55 cproensa Assigned To => cproensa
2018-10-25 19:55 cproensa Status new => assigned
2018-10-25 19:55 cproensa Note Added: 0060858
2018-11-01 12:52 dregad Changeset attached => MantisBT master 0041c91e
2018-11-01 12:52 cproensa Status assigned => resolved
2018-11-01 12:52 cproensa Resolution open => fixed
2018-11-01 12:52 cproensa Fixed in Version => 2.19.0
2018-11-01 12:58 atrol Target Version => 2.19.0