View Issue Details

IDProjectCategoryView StatusLast Update
0024976mantisbtuipublic2019-01-02 17:25
ReporterzdenekAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.13.0 
Target Version2.19.0Fixed in Version2.19.0 
Summary0024976: Sidebar's collapsed state is not preserved
Description

If I collapse the left sidebar (buttons My View, View Issues, ...) and navigate to another issue, the sidebar is show in uncollapsed state.

It would be nice if the sidebar's state was preserved through all pages.

TagsNo tags attached.

Activities

atrol

atrol

2018-11-14 14:52

developer   ~0060961

Are you able to reproduce it on https://www.mantisbt.org/bugs ?

zdenek

zdenek

2018-11-14 15:03

reporter   ~0060962

Yes, I'm.
I tried it in "Chrome Version 70.0.3538.102" and "Vivaldi 1.15.1147.42"

atrol

atrol

2018-11-14 16:16

developer   ~0060963

Changed version, as the bug has been introduced in 2.13.0.
Will provide a fix for it.

atrol

atrol

2018-11-14 16:24

developer   ~0060964

PR https://github.com/mantisbt/mantisbt/pull/1409

zdenek

zdenek

2018-11-15 01:54

reporter   ~0060965

I've tried your patch and it works like a charm.
Thx for quick response.

atrol

atrol

2018-11-15 02:08

developer   ~0060966

Thanks @zdenek for confirming the fix.

Related Changesets

MantisBT: master b5ea0dd1

2018-11-16 09:26:43

dregad


Committer: atrol Details Diff
Proper fix for duplicate 'sidebar' div ID

The initial attempt at fixing this issue [1] introduced a regression in
the persistence of the sidebar's collapse state.

Using a different ID for the toggle button or the sidebar div caused
other issues (e.g. malfunctioning hambuger menu on narrow screens, or
failure to save collapse state).

The root cause was a bug in the javascript code saving the sidebar's
state, which was referencing the toggle button's id instead of the
sidebar div's.

We now have ID 'sidebar' for the actual sidebar, and 'sidebar-btn' for
the toggle button, and the javascript has been modified accordingly.

Fixes 0024976

[1]: commit b7b914549fe8fbdf4ee4053f475031df9d6a4674
Affected Issues
0024976
mod - core/layout_api.php Diff File
mod - js/common.js Diff File

Issue History

Date Modified Username Field Change
2018-11-14 14:40 zdenek New Issue
2018-11-14 14:52 atrol Status new => feedback
2018-11-14 14:52 atrol Note Added: 0060961
2018-11-14 15:03 zdenek Note Added: 0060962
2018-11-14 15:03 zdenek Status feedback => new
2018-11-14 16:13 atrol Assigned To => atrol
2018-11-14 16:13 atrol Status new => assigned
2018-11-14 16:16 atrol Product Version 2.18.0 => 2.13.0
2018-11-14 16:16 atrol Target Version => 2.19.0
2018-11-14 16:16 atrol Note Added: 0060963
2018-11-14 16:24 atrol Note Added: 0060964
2018-11-15 01:54 zdenek Note Added: 0060965
2018-11-15 02:08 atrol Note Added: 0060966
2018-11-18 08:29 atrol Changeset attached => MantisBT master b5ea0dd1
2018-11-18 08:29 dregad Assigned To atrol => dregad
2018-11-18 08:29 dregad Status assigned => resolved
2018-11-18 08:29 dregad Resolution open => fixed
2018-11-18 08:29 dregad Fixed in Version => 2.19.0
2019-01-02 17:25 vboctor Status resolved => closed