View Issue Details

IDProjectCategoryView StatusLast Update
0025129mantisbtcode cleanuppublic2019-01-02 17:25
Reporterdregad Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target Version1.3.17Fixed in Version1.3.17 
Summary0025129: Remove usage of deprecated function __autoload
Description

__autoload has been deprecated as of PHP 7.2 [1][2]

We have an implementation of function __autoload in core.php.
Therefore, according a user in forum, you get messages in PHP log when using PHP 7.2 [3]

I had a short look at it and found that we are using __autoload and spl_autoload_register.

I have no time to have a deeper look at the moment, maybe we have just to rename __autoload and use it as parameter for spl_autoload_register.

[1] http://php.net/manual/en/migration72.deprecated.php
[2] http://php.net/manual/en/function.autoload.php
[3] https://www.mantisbt.org/forums/viewtopic.php?f=2&t=25177

Additional Information

This is a clone of 0023710 to keep track of backporting the fix to 1.3.x branch

TagsNo tags attached.

Relationships

duplicate of 0023710 closedvboctor Remove usage of deprecated function __autoload 

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master-1.3.x 86232c21

2017-12-10 16:45:43

atrol


Committer: dregad Details Diff
Don't use deprecated __autoload

Fixes 0025129

Backported from 0c535cf2ec74640c8ac85946c60445325aa26787 (Issue 0023710)
Affected Issues
0023710, 0025129
mod - core.php Diff File

Issue History

Date Modified Username Field Change
2018-12-29 08:40 dregad New Issue
2018-12-29 08:40 dregad Status new => assigned
2018-12-29 08:40 dregad Assigned To => dregad
2018-12-29 08:40 dregad Issue generated from: 0023710
2018-12-29 08:40 dregad Relationship added duplicate of 0023710
2018-12-29 08:41 dregad Changeset attached => MantisBT master-1.3.x 86232c21
2018-12-29 08:41 atrol Assigned To dregad => atrol
2018-12-29 08:41 atrol Status assigned => resolved
2018-12-29 08:41 atrol Resolution open => fixed
2018-12-29 08:41 atrol Fixed in Version => 1.3.17
2019-01-02 17:25 vboctor Status resolved => closed