View Issue Details

IDProjectCategoryView StatusLast Update
0025181mantisbtcustom fieldspublic2019-01-20 03:30
ReportersmartmantisAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version2.19.0 
Target VersionFixed in Version 
Summary0025181: string_custom_field_value function can pass p_bug_id as parameter
Description

We use generated custom fields and want to see them it on the view issues page too , so we need the bug_id as parameter in the user function call:

in function string_custom_field_value:
original:
return call_user_func( $g_custom_field_type_definition[$p_def['type']]['#function_string_value'], $t_custom_field_value );
fixed line:
return call_user_func( $g_custom_field_type_definition[$p_def['type']]['#function_string_value'], $t_custom_field_value , $p_bug_id);

if that's possible please add this to the core, because we need always patch it after the upgrades, and i think it could be useful for the others too.

TagsNo tags attached.

Relationships

duplicate of 0005942 new string_custom_field_value - custom function 

Activities

smartmantis

smartmantis

2019-01-09 09:14

reporter   ~0061171

it was a topic earlier
https://www.mantisbt.org/bugs/view.php?id=5942

i found my comment from 2011...
:)

dregad

dregad

2019-01-09 09:18

developer   ~0061172

it was a topic earlier https://www.mantisbt.org/bugs/view.php?id=5942

In that case I'll resolve this one as duplicate...

smartmantis

smartmantis

2019-01-09 11:28

reporter   ~0061174

please update 5942 product verison in this case

Issue History

Date Modified Username Field Change
2019-01-09 09:12 smartmantis New Issue
2019-01-09 09:14 smartmantis Note Added: 0061171
2019-01-09 09:18 dregad Assigned To => dregad
2019-01-09 09:18 dregad Status new => resolved
2019-01-09 09:18 dregad Resolution open => duplicate
2019-01-09 09:18 dregad Note Added: 0061172
2019-01-09 09:18 dregad Relationship added duplicate of 0005942
2019-01-09 11:28 smartmantis Note Added: 0061174
2019-01-20 03:30 atrol Status resolved => closed