View Issue Details

IDProjectCategoryView StatusLast Update
0025237mantisbtintegrationpublic2019-09-16 20:15
Reportertruefriend-cz Assigned Todregad  
PrioritylowSeverityminorReproducibilityhave not tried
Status assignedResolutionreopened 
Product Version2.19.0 
Summary0025237: Rewrite URL and server path from htaccess
Description

I have problem with compatibility Mantis and .htaccess file for rewriting subdomain to directory

Steps To Reproduce

If have .htaccess in the root file for rewrite URL subdomain to directory:
My domain is http://bugs.domain.tld
and system path for Mantis is /etc/apache2/www/root/bugs

.htaccess:

# subdomain to directory
RewriteCond %{HTTP_HOST} !^www\.domain\.tld$
RewriteCond %{HTTP_HOST} ^(\w+)\.domain\.tld$
RewriteCond %{REQUEST_URI}:%1 !^/([^/]+)/([^:]*):\1
RewriteRule ^(.*)$ /%1/$1 [QSA]

then on the webpage Mantis systemhave URLs for click ("a href" in html code) in format http://bugs.domain.tld/bugs/bug_report_page.php

i wanted domain in format http://bugs.domain.tld/bug_report_page.php

Additional Information

I am a little english

TagsNo tags attached.

Activities

truefriend-cz

truefriend-cz

2019-01-22 00:05

reporter   ~0061268

Please pair with this: https://www.mantisbt.org/bugs/view.php?id=25364

truefriend-cz

truefriend-cz

2019-01-30 20:29

reporter   ~0061339

Last edited: 2019-01-30 20:37

View 5 revisions

Next info...
Details is at forum - https://www.mantisbt.org/forums/viewtopic.php?f=3&t=26107
(edit: i dont know why show link to forum after click show as "The requested topic does not exist.". Topic on forum is normally existed.
It is in "Board index -> MantisBT -> English -> Help -> URL format" from Jan 27, 2019 10:18 am.
Maybe have Mantis script problem with external URL links too.)

Untitled-1.png (39,893 bytes)   
Untitled-1.png (39,893 bytes)   
Untitled-2.png (40,760 bytes)   
Untitled-2.png (40,760 bytes)   
Untitled-3.png (30,778 bytes)   
Untitled-3.png (30,778 bytes)   
Untitled-4.png (17,484 bytes)   
Untitled-4.png (17,484 bytes)   
dregad

dregad

2019-09-06 03:27

developer   ~0062739

truefriend-cz,

This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

truefriend-cz

truefriend-cz

2019-09-06 10:14

reporter   ~0062745

Well, you could have sent me to hell better. So I'm waiting 9 months for a solution to send me to fuck.
I used that place. And they sent me back here. If I knew you'd react like this, I wouldn't report it. I can't solve the problem myself. So thank you very much. Have a nice day.
https://mantisbt.org/forums/viewtopic.php?f=3&t=26107

truefriend-cz

truefriend-cz

2019-09-16 19:42

reporter   ~0062829

Link removed

truefriend-cz

truefriend-cz

2019-09-16 19:43

reporter   ~0062830

Why link after add this place removed from Forum??? Before is link ok.

truefriend-cz

truefriend-cz

2019-09-16 19:48

reporter   ~0062831

Last edited: 2019-09-16 19:49

View 2 revisions

Ok, link is moved. New link is:
'''
https://mantisbt.org/forums/viewtopic.php?f=4&t=26084
'''
And the answers to this post were deleted by someone.

WHY???!!! The author of the post did not remove it.

truefriend-cz

truefriend-cz

2019-09-16 20:15

reporter   ~0062832

Sorry. URL format has been changed in your script.
And I have two similar questions on your forum.

Issue History

Date Modified Username Field Change
2019-01-16 13:48 truefriend-cz New Issue
2019-01-22 00:05 truefriend-cz Note Added: 0061268
2019-01-30 20:29 truefriend-cz File Added: Untitled-1.png
2019-01-30 20:29 truefriend-cz File Added: Untitled-2.png
2019-01-30 20:29 truefriend-cz File Added: Untitled-3.png
2019-01-30 20:29 truefriend-cz File Added: Untitled-4.png
2019-01-30 20:29 truefriend-cz Note Added: 0061339
2019-01-30 20:31 truefriend-cz Note Edited: 0061339 View Revisions
2019-01-30 20:34 truefriend-cz Note Edited: 0061339 View Revisions
2019-01-30 20:37 truefriend-cz Note Edited: 0061339 View Revisions
2019-01-30 20:37 truefriend-cz Note Edited: 0061339 View Revisions
2019-09-06 03:27 dregad Assigned To => dregad
2019-09-06 03:27 dregad Status new => resolved
2019-09-06 03:27 dregad Resolution open => no change required
2019-09-06 03:27 dregad Note Added: 0062739
2019-09-06 10:14 truefriend-cz Note Added: 0062745
2019-09-16 14:30 atrol Status resolved => closed
2019-09-16 19:42 truefriend-cz Status closed => feedback
2019-09-16 19:42 truefriend-cz Resolution no change required => reopened
2019-09-16 19:42 truefriend-cz Note Added: 0062829
2019-09-16 19:43 truefriend-cz Note Added: 0062830
2019-09-16 19:43 truefriend-cz Status feedback => assigned
2019-09-16 19:48 truefriend-cz Note Added: 0062831
2019-09-16 19:49 truefriend-cz Note Edited: 0062831 View Revisions
2019-09-16 20:15 truefriend-cz Note Added: 0062832