View Issue Details

IDProjectCategoryView StatusLast Update
0025366mantisbtintegrationpublic2020-03-10 17:23
Reportertruefriend-cz Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version2.19.0 
Summary0025366: SYSTEM WARNING - error_log problem
Description

After adding to config_inc.php this:
$g_display_errors = array(
E_WARNING => 'halt',
E_NOTICE => 'halt',
E_USER_ERROR => 'halt',
E_USER_WARNING => 'halt',
E_USER_NOTICE => 'halt'
);
$g_show_detailed_errors = ON;
and cretating new report (ticket) after click for reporting show error.

Steps To Reproduce

SYSTEM WARNING

'error_log(/var/log/mantisbt.log): failed to open stream: Permission denied' in '/var/home/doamin.tld/public_html/bugs/core/logging_api.php' line 109

Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.
Detailed error information
Full path: /var/home/domain.tld/public_html/bugs/core/logging_api.php
Line number: 109
Stack trace

Filename Line Class Type Function Args

0 /var/home/domain.tld/public_html/bugs/core/logging_api.php 109 - - error_log <string>'2019-01-21 22:17:18 MAIL email_api.php:946 email_bug_added() Issue #14 reported ', <integer>3, <string>'/var/log/mantisbt.log'
1 /var/home/domain.tld/public_html/bugs/core/email_api.php 946 - - log_event <integer>1, <string>'Issue #14 reported'
2 /var/home/domain.tld/public_html/bugs/core/commands/IssueAddCommand.php 448 - - email_bug_added <integer>14
3 /var/home/domain.tld/public_html/bugs/core/commands/Command.php 137 IssueAddCommand -> process -
4 /var/home/domain.tld/public_html/bugs/bug_report.php 246 Command -> execute -

Additional Information

Legend:
domain.tld in reproduction problem is replaced strings of my domain.
Sorry my little english

TagsNo tags attached.

Relationships

duplicate of 0025734 closeddregad LOGFILE_NOT_WRITABLE error triggered if file does not exist 

Activities

truefriend-cz

truefriend-cz

2019-01-21 16:22

reporter   ~0061266

...problem tested on 2.5 servers.

  1. webhosting provider service
  2. localhost on XAMPP server, and USBWebserver V8
dregad

dregad

2020-02-25 10:59

developer   ~0063687

Seems to be a duplicate of 0025734 (fixed in 2.21.1).

Issue History

Date Modified Username Field Change
2019-01-21 16:19 truefriend-cz New Issue
2019-01-21 16:22 truefriend-cz Note Added: 0061266
2020-02-25 10:59 dregad Assigned To => dregad
2020-02-25 10:59 dregad Status new => resolved
2020-02-25 10:59 dregad Resolution open => duplicate
2020-02-25 10:59 dregad Note Added: 0063687
2020-02-25 10:59 dregad Relationship added duplicate of 0025734
2020-02-25 11:00 dregad Priority urgent => normal
2020-02-25 11:00 dregad Severity block => minor
2020-03-10 17:23 atrol Status resolved => closed