View Issue Details

IDProjectCategoryView StatusLast Update
0025368mantisbtadministrationpublic2019-03-16 20:20
Reportercproensa Assigned Tocproensa  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.20.0 
Target Version2.20.0Fixed in Version2.20.0 
Summary0025368: Manage project, copy from/to forms are easy to click accidentally and don't ask for confirmation
Description

The forms to copy versions, custom fields, users, etc from another project, or into another project, don't ask for user confirmation.
The placement of these forms are very close to the standard management areas, so there is a risk for the user to accidentally click those.

Fixing the mess after one of those accidents, for example users, is difficult because usually there's a lot of items copied.

TagsNo tags attached.

Activities

Related Changesets

MantisBT: master f37dffa5

2019-01-23 06:28:38

cproensa


Committer: dregad Details Diff
Manage project page, safe copy from/to forms

In manage project edit page, make the forms in each section for copying
items to/from other projects to not have an initial project as selected,
and make the selection as required.
This avoid to accidentally use this actions, without having made an
explicit selection in them.

Fixes: 0025368
Affected Issues
0025368
mod - manage_proj_edit_page.php Diff File

Issue History

Date Modified Username Field Change
2019-01-21 19:57 cproensa New Issue
2019-01-23 06:32 cproensa Assigned To => cproensa
2019-01-23 06:32 cproensa Status new => assigned
2019-01-23 18:04 cproensa Note Added: 0061285
2019-03-02 19:13 dregad Changeset attached => MantisBT master f37dffa5
2019-03-02 19:13 cproensa Status assigned => resolved
2019-03-02 19:13 cproensa Resolution open => fixed
2019-03-02 19:13 cproensa Fixed in Version => 2.20.0
2019-03-03 16:43 atrol Target Version => 2.20.0
2019-03-05 16:53 cproensa Category ui => administration
2019-03-16 20:20 vboctor Status resolved => closed