View Issue Details

IDProjectCategoryView StatusLast Update
0025403mantisbtdocumentationpublic2019-03-16 20:20
Reportermushu Assigned Toatrol  
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version2.20.0Fixed in Version2.20.0 
Summary0025403: $g_notify_new_user_created_threshold_min is ignored on new account creation
Description

As I read the docs, only accounts with the minimum level set in $g_notify_new_user_created_threshold_min should get the email that a new account was created, however it sends the notice to the person who got the new account. Since I created about 1000 accounts all at once I don't know if it also sent me (the admin) an email notice or not. My understanding is that Mantis should check this variable level prior to sending a new account creation email and only send the message if that account is at least as high as what's in $g_notify_new_user_created_threshold_min

Steps To Reproduce

see description above

Additional Information

If this is an incorrect assumption on the part of the program then the documentation needs to be updated or written better to reflect the actual intent of this variable.

TagsNo tags attached.

Activities

mushu

mushu

2019-01-30 17:27

reporter   ~0061338

Mantis ver 2.18.0

atrol

atrol

2019-01-31 03:30

developer   ~0061348

If this is an incorrect assumption on the part of the program then the documentation needs to be updated or written better to reflect the actual intent of this variable.

I checked the information for this option in Admin Guide and config_defaults_inc,php and from what I see, the option does exactly what is documented.

if email notifications ($g_enable_email_notification) is
    set to ON, users with access level about
    $g_notify_new_user_created_threshold_min will get a
    notification that a user account has been created.  Information
    about the user like user name, email address, IP address are included in
    the email notification
/**
 * access level required to be notified when a new user has been created using
 * the "signup form"
 * @global integer $g_notify_new_user_created_threshold_min
 */

Keep in mind, that when talking about $g_notify_new_user_created_threshold_min, we are talking about emails like the following one:

The following account has been created:

Username: testUser
E-mail: testUser@myMail.com
Remote IP address: xx.xxx.xxx.xx
https://www.mantisbt.org/bugs/

Do not reply to this message

however it sends the notice to the person who got the new account.

I am pretty sure, your are not talking about the documented notice, but another one.

Feel free to reopen the issue if the new account should get notifications where something like Remote IP address: xx.xxx.xxx.xx is part of the email.

mushu

mushu

2019-01-31 10:31

reporter   ~0061349

Last edited: 2019-01-31 10:53

View 4 revisions

The word "min" in that variable tells me that the setting is a minimum level to receive emails. Since the new user gets the email, and I have that variable set to ADMINISTRATOR then it stands to reason that a new user account below admin level should not get the email. Here is a sample email they all got:

=====
From: MantisBugTracker <devbugs@our-domain>
Sent: Wednesday, January 30, 2019 1:41 PM
To: Lastname, Firstname-of-user
Subject: [Mantis(DEV)] Account registration 

The user my-user-name has created an account for you with username "their-user-name". In order
to report an issue or view the status, visit the following URL:
http://our-server-name:8888/

http://our-server-name:8888/verify.php?id=403&confirm_hash=QZKYxT-fQsuxgR5UA3g6MHODSefe5GpMQRpQfw3JlmiZzblEl4KizECAyZNl-DzJq9-jI6OxNT-0MCkUpvWl

Do not reply to this message
=====

I need to have Mantis NOT send the customer an email that they just had an account created.

Also: in the description for that variable in the docs, the word "about" is ambiguous and should be changed to "near" or "at least". What does "about the variable setting" mean? Is that some type of local vernacular?

EDIT: not sure how to modify the font size or why it is so big.

atrol

atrol

2019-01-31 11:09

developer   ~0061350

the word "about" is ambiguous and should be changed

I will fix this and change the word to "above".

But still: There is no bug in functionality.
Please read again very carefully my note 0025403:0061348.

EDIT: not sure how to modify the font size or why it is so big.

I changed it. It was so big because of the way how Markdown works. https://github.com/adam-p/markdown-here/wiki/Markdown-Cheatsheet
Your text was interpreted as headers.

atrol

atrol

2019-02-01 02:43

developer   ~0061358

Doc fix is part of PR https://github.com/mantisbt/mantisbt/pull/1454

Related Changesets

MantisBT: master c29137eb

2019-01-31 11:14:56

atrol

Details Diff
Correct documentation of $g_notify_new_user_created_threshold_min

Fixes 0025403
Affected Issues
0025403
mod - docbook/Admin_Guide/en-US/User_Management.xml Diff File

Issue History

Date Modified Username Field Change
2019-01-30 17:26 mushu New Issue
2019-01-30 17:27 mushu Note Added: 0061338
2019-01-31 03:30 atrol Assigned To => atrol
2019-01-31 03:30 atrol Status new => resolved
2019-01-31 03:30 atrol Resolution open => no change required
2019-01-31 03:30 atrol Note Added: 0061348
2019-01-31 10:31 mushu Status resolved => feedback
2019-01-31 10:31 mushu Resolution no change required => reopened
2019-01-31 10:31 mushu Note Added: 0061349
2019-01-31 10:32 mushu Note Edited: 0061349 View Revisions
2019-01-31 10:32 mushu Note Edited: 0061349 View Revisions
2019-01-31 10:53 atrol Note Edited: 0061349 View Revisions
2019-01-31 11:04 atrol Severity major => text
2019-01-31 11:04 atrol Category email => documentation
2019-01-31 11:04 atrol Status feedback => assigned
2019-01-31 11:04 atrol Target Version => 2.20.0
2019-01-31 11:09 atrol Note Added: 0061350
2019-02-01 02:43 atrol Note Added: 0061358
2019-02-02 15:51 atrol Changeset attached => MantisBT master c29137eb
2019-02-02 15:51 atrol Status assigned => resolved
2019-02-02 15:51 atrol Resolution reopened => fixed
2019-02-02 15:51 atrol Fixed in Version => 2.20.0
2019-03-16 20:20 vboctor Status resolved => closed