View Issue Details

IDProjectCategoryView StatusLast Update
0025456mantisbtsqlpublic2019-03-16 20:20
Reportercproensa Assigned Tocproensa  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.20.0 
Target Version2.20.0Fixed in Version2.20.0 
Summary0025456: Page adm_config_report has queries missing db_param_push()
Description

Two queries in this page use db_param() without using db_param_push().

I am not sure if it may still be a problem after rewriting the query subsytem, but it's good to clean it up just in case.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master f0d4f661

2019-02-07 13:09:43

cproensa


Committer: vboctor Details Diff
Fix adm_config_report user list

The code to build the user dropdown list have some issues:
- Missing db_param_push()
- Calls to get user names are not cached generating a lot of separate
queries for individual user ids
- User names are not properly ordered in the dropdown list, as it's
sorting with a case sensitive mode.

Fixes: 0025454, 0025455, 0025456
Affected Issues
0025454, 0025455, 0025456
mod - adm_config_report.php Diff File

MantisBT: master d55ad54e

2019-02-07 13:34:46

cproensa


Committer: vboctor Details Diff
Fix adm_config_report query

The main query has a missing db_param_push(), but because of how the
query is built, it should only be used only when any of the conditions
are actually adding a parameter.
To simplyfy, the query has been rewritten with the new syntax.

Fixes: 0025456
Affected Issues
0025456
mod - adm_config_report.php Diff File

Issue History

Date Modified Username Field Change
2019-02-07 13:42 cproensa New Issue
2019-02-07 13:42 cproensa Status new => assigned
2019-02-07 13:42 cproensa Assigned To => cproensa
2019-02-24 16:42 vboctor Changeset attached => MantisBT master f0d4f661
2019-02-24 16:42 vboctor Changeset attached => MantisBT master d55ad54e
2019-02-24 16:42 cproensa Status assigned => resolved
2019-02-24 16:42 cproensa Resolution open => fixed
2019-02-24 16:42 cproensa Fixed in Version => 2.20.0
2019-02-24 16:43 vboctor Target Version => 2.20.0
2019-03-16 20:20 vboctor Status resolved => closed