View Issue Details

IDProjectCategoryView StatusLast Update
0025561mantisbtadministrationpublic2019-04-20 02:37
Reporterdanfalco Assigned Todregad  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionno change required 
Product Version1.3.17 
Target VersionFixed in Version 
Summary0025561: Reports visible to all
Description

I'm sorry, maybe it's not the right place. I would like to know if it is possible to make sure that all the reporters can (only) see the issues posted by the others. I have created a (public) project, I have included a report with a user (manager) and I would like everyone else to be able to view it.
If this is possible, how to set up projects and users?
Thank you so much

TagsNo tags attached.

Activities

dregad

dregad

2019-03-04 11:07

developer   ~0061621

Your requirement is not really clear.

reporters can (only) see the issues posted by the others

Meaning seeing all issues except the ones that they reported themselves ? That does not make much sense...

Also, what "others" ? reporters, users ?

danfalco

danfalco

2019-03-07 04:32

reporter   ~0061644

No. We have set up users who can post bugs. Currently, however, each user is able to view only their own bugs, because so we had decided to do when we installed the software, while now we would like to allow each user to be visible all the bugs entered by all users. I think it's a trivial thing indeed, but I can not configure this way, can you give me an indication even if we have a rather old version installed? Perhaps now I have been clearer. Thank you so much

dregad

dregad

2019-03-07 12:15

developer   ~0061645

You probably want to set $g_limit_reporters = OFF; in your config

https://github.com/mantisbt/mantisbt/blob/release-2.19.0/config_defaults_inc.php#L3032

danfalco

danfalco

2019-03-08 08:43

reporter   ~0061652

Thank You.
The problem was different. In our old version of the software, those who had configured it had made all the projects private and then added the following rule in configuration:
All users All projects private_bug_threshold integer 55
that made projects visible but only to managers.
I changed it to:
All users All projects private_bug_threshold integer 25
then enabling reporters and leaving the projects private.
Thanks anyway

dregad

dregad

2019-03-08 10:14

developer   ~0061653

Thanks for the feedback.

Related Changesets

MantisBT: master-2.20 acdadb87

2019-04-18 06:24:40

dregad

Details Diff
Use true instead of null for $p_obsolete param

As discussed in PR https://github.com/mantisbt/mantisbt/pull/1492#discussion_r270359921
the semantics of the $p_obsolete parameter have changed, so the proper
fix for the regression (issue 0025561), is to update the callers to use
`true` instead of `null`.

This commit addresses the 3 identified occurrences of such calls to
version_get_all_rows().
Affected Issues
0025561
mod - api/soap/mc_project_api.php Diff File
mod - core/print_api.php Diff File
mod - manage_proj_edit_page.php Diff File

Issue History

Date Modified Username Field Change
2019-03-04 10:11 danfalco New Issue
2019-03-04 11:07 dregad Status new => feedback
2019-03-04 11:07 dregad Note Added: 0061621
2019-03-07 04:32 danfalco Note Added: 0061644
2019-03-07 04:32 danfalco Status feedback => new
2019-03-07 12:15 dregad Status new => feedback
2019-03-07 12:15 dregad Note Added: 0061645
2019-03-08 08:43 danfalco Note Added: 0061652
2019-03-08 08:43 danfalco Status feedback => new
2019-03-08 10:14 dregad Assigned To => dregad
2019-03-08 10:14 dregad Status new => resolved
2019-03-08 10:14 dregad Resolution open => no change required
2019-03-08 10:14 dregad Note Added: 0061653
2019-03-16 20:21 vboctor Status resolved => closed
2019-04-20 02:37 dregad Changeset attached => MantisBT master-2.20 acdadb87