View Issue Details

IDProjectCategoryView StatusLast Update
0025622mantisbtprintingpublic2022-05-22 14:56
Reportervboctor Assigned Todregad  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionduplicate 
Product Version2.20.0 
Summary0025622: print_all_bug_page_word.php runs out of memory
Description

If print_all_bug_page_word.php is called without a filter in issues to print, it runs out of memory on an instance with a lot of issues.

TagsNo tags attached.

Relationships

duplicate of 0022224 resolveddregad Access Restrictions to "Print Reports", "CSV Export", "Excel Export" in view all bugs page 

Activities

vboctor

vboctor

2019-03-19 01:43

manager   ~0061707

Last edited: 2022-05-12 08:43

As a workaround for potential DOS attacks, do the following:

  • Disable the print_all_bug_page.php and print_all_bug_page_word.php for anonymous user via access_denied().
  • Disable the same for users that don't have global access level of developer.
atrol

atrol

2019-03-19 02:26

developer   ~0061708

See also 0022224 https://github.com/mantisbt/mantisbt/pull/1021

dregad

dregad

2022-05-12 08:48

developer   ~0066568

After reviewing and testing 0022224, I realize that the proposed fix implements what @vboctor suggested in 0025622:0061707, so I'm closing this as duplicate.