View Issue Details

IDProjectCategoryView StatusLast Update
0025752mantisbtadministrationpublic2019-05-20 12:33
ReporterkeessonnemaAssigned Todregad 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version2.21.0 
Target VersionFixed in Version 
Summary0025752: When changing role for a project the role is changed for every project
Description

I've tried changing the role of a user to manager, but now this user is manager for all the projects in our db.
I don't know in which version this bug occurred, but I think this is since 2.20.0

On a side note: I think there is no way to actually change this back. Whenever I change the status to something else all projects are changed.

TagsNo tags attached.

Relationships

duplicate of 0025722 resolvedcproensa Wrong access_level settings when updating rights in the project admin page 

Activities

keessonnema

keessonnema

2019-05-10 05:20

reporter   ~0062051

Last edited: 2019-05-10 05:22

View 2 revisions

Steps to reproduce (forgot to add):

  • Select a project

  • Scroll down to the userlist

  • Pick a user and change the role for that user
    Save

  • Go to the previously edited user

  • Scroll down to his projects

  • All the roles are set to the status that you set in the previous steps

Edit: Still exists in 2.21.0

dregad

dregad

2019-05-10 05:45

developer   ~0062052

Looks like a duplicate of 0025722.

Since @vboctor has not released 2.21.1 yet, you can download a nightly build from http://mantisbt.org/builds.php

Issue History

Date Modified Username Field Change
2019-05-10 05:03 keessonnema New Issue
2019-05-10 05:20 keessonnema Note Added: 0062051
2019-05-10 05:22 keessonnema Note Edited: 0062051 View Revisions
2019-05-10 05:45 dregad Assigned To => dregad
2019-05-10 05:45 dregad Status new => resolved
2019-05-10 05:45 dregad Resolution open => duplicate
2019-05-10 05:45 dregad Note Added: 0062052
2019-05-10 05:45 dregad Relationship added duplicate of 0025722
2019-05-20 12:33 atrol Status resolved => closed