View Issue Details

IDProjectCategoryView StatusLast Update
0025815mantisbtbugtrackerpublic2019-08-25 12:36
Reporterdregad Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Target Version2.22.0Fixed in Version2.22.0 
Summary0025815: Users can't add monitors if access < show_monitor_list_threshold and >= monitor_add_others_bug_threshold
Description

In View Issue Page, the Users monitoring this issue box is only displayed if the user has $g_show_monitor_list_threshold. If the same user had $g_monitor_add_others_bug_threshold, they would not be able to adding new monitors.

This is an uncommon situation, as monitor_add_others_bug_threshold is expected to be >= show_monitor_list_threshold. Still it makes sense to fix that since the configuration allows such setup.

Additional Information

Following discussion in https://github.com/mantisbt/mantisbt/pull/1513#pullrequestreview-239254128

TagsNo tags attached.

Relationships

related to 0006128 closeddregad Ability to add monitors to a bug when the bug is first reported 
related to 0025826 closeddregad Impossible to set add/remove monitors thresholds from manage page 
related to 0025827 closeddregad Improve documentation for monitors-related configs 
related to 0012557 new Bug view page: add monitoring for user select from list 

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master e5a8ca4a

2019-05-30 12:50:13

dregad

Details Diff
Let users add monitors even if they can't see them

In view.php, the 'Users monitoring this issue' box is only displayed
if the user has $g_show_monitor_list_threshold. If the same user had
$g_monitor_add_others_bug_threshold, they would not be able to adding
new monitors.

This is an uncommon situation, as monitor_add_others_bug_threshold is
expected to be >= show_monitor_list_threshold. Still it makes sense to
fix that since the configuration allows such setup.

With this change, an 'Access Denied' message is displayed instead of the
users' list if access level is below show_monitor_list_threshold and
>= monitor_add_others_bug_threshold, and the form to add new monitors is
shown.

If user's access level is lower than both thresholds, then the behavior
is unchanged, i.e. the whole box is hidden.

Fixes 0025815
Affected Issues
0025815
mod - bug_monitor_list_view_inc.php Diff File

Issue History

Date Modified Username Field Change
2019-05-30 12:56 dregad New Issue
2019-05-30 12:56 dregad Status new => assigned
2019-05-30 12:56 dregad Assigned To => dregad
2019-05-30 12:56 dregad Additional Information Updated View Revisions
2019-05-30 12:56 dregad Relationship added related to 0006128
2019-05-31 08:55 dregad Relationship added related to 0025826
2019-05-31 09:00 dregad Relationship added related to 0025827
2019-06-03 03:12 dregad Changeset attached => MantisBT master e5a8ca4a
2019-06-03 03:12 dregad Status assigned => resolved
2019-06-03 03:12 dregad Resolution open => fixed
2019-06-03 03:12 dregad Fixed in Version => 2.22.0
2019-06-05 09:27 dregad Relationship added related to 0012557
2019-08-25 12:36 vboctor Status resolved => closed