View Issue Details

IDProjectCategoryView StatusLast Update
0025856mantisbtapi soappublic2019-06-11 06:37
Reporterdregad Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.8 
Target Version1.3.19Fixed in Version1.3.19 
Summary0025856: SOAP API return value does not match definition in WSDL
Description

on success the function mc_project_version_update() returns FALSE, i.e. the nonexistent return value of version_update() which is casted to NULL on several implementations.

on an older version (1.2.19) version_update() returned true on success

Additional Information

Clone of 0025470 for tracking in 1.3.x changelog

TagsNo tags attached.

Relationships

duplicate of 0025470 resolveddregad SOAP API return value does not match definition in WSDL 

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master-1.3.x 7b06ee38

2019-06-05 04:59:47

dregad

Details Diff
Fix mc_project_version_update() return value

The function's return type does not match the WSDL definition.

This is a regression introduced by a80f447687722b52160d00c96c21a5be5f4329e1
which changed version_update()'s return type from true (bool) to void
Since mc_project_version_update() actually returned that, it causes a
side effect because void == NULL == false.

To avoid an unnecessary and potentially breaking change in the WSDL, the
function now returns true.

Fixes 0025856

(cherry picked from commit a309d0ab758bec99bc42643981545e730b3f6a81)
Affected Issues
0025856
mod - api/soap/mc_project_api.php Diff File

MantisBT: master-1.3.x 404e3df8

2019-06-05 05:15:19

dregad

Details Diff
Fix mc_project_version_delete() return value

The function's return type does not match the WSDL definition.

This is a regression introduced by a80f447687722b52160d00c96c21a5be5f4329e1
which changed version_delete()'s return type from true (bool) to void
Since mc_project_version_delete() actually returned that, it causes a
side effect because void == NULL == false.

To avoid an unnecessary and potentially breaking change in the WSDL, the
function now returns true.

Fixes 0025856

(cherry picked from commit 5039c7b86a21f41a64c904e3eb16e0eb25ac2cb0)
Affected Issues
0025856
mod - api/soap/mc_project_api.php Diff File

Issue History

Date Modified Username Field Change
2019-06-11 06:32 dregad New Issue
2019-06-11 06:32 dregad Status new => assigned
2019-06-11 06:32 dregad Assigned To => dregad
2019-06-11 06:32 dregad Issue generated from: 0025470
2019-06-11 06:32 dregad Relationship added duplicate of 0025470
2019-06-11 06:33 dregad Changeset attached => MantisBT master-1.3.x 7b06ee38
2019-06-11 06:33 dregad Changeset attached => MantisBT master-1.3.x 404e3df8
2019-06-11 06:33 dregad Status assigned => resolved
2019-06-11 06:33 dregad Resolution open => fixed
2019-06-11 06:33 dregad Fixed in Version => 1.3.19
2019-06-11 06:37 dregad Summary SOAP API return does not match definition in WSDL => SOAP API return value does not match definition in WSDL