View Issue Details

IDProjectCategoryView StatusLast Update
0025915mantisbtattachmentspublic2019-07-11 07:23
ReporterABS Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.21.0 
Target VersionFixed in Version 
Summary0025915: setting $g_default_bugnote_view_status to private prevent normal users to post attachments
Description

when you set $g_default_bugnote_view_status = VS_PRIVATE; in config_inc.php a reporter wouldn't be able to post any attachment since the note is set to private and he can't change this so the field to post attachment wouldn't even appear. I've found a way to solve that (by adding the highlighted part in bugnote_add_inc.php see screen chot) but it would be great if it worked naturally.

TagsNo tags attached.

Relationships

duplicate of 0022817 confirmed "private bugnotes" as default setting prevents uploading further attachments 

Activities

ABS

ABS

2019-07-10 11:29

reporter  

bug report.PNG (14,714 bytes)
bug report.PNG (14,714 bytes)
atrol

atrol

2019-07-10 14:45

developer   ~0062376

Is 0022817 the same issie?

ABS

ABS

2019-07-11 05:55

reporter   ~0062377

Yes, sorry I didn't saw this issue

Issue History

Date Modified Username Field Change
2019-07-10 11:29 ABS New Issue
2019-07-10 11:29 ABS File Added: bug report.PNG
2019-07-10 14:45 atrol Status new => feedback
2019-07-10 14:45 atrol Note Added: 0062376
2019-07-11 05:55 ABS Note Added: 0062377
2019-07-11 05:55 ABS Status feedback => new
2019-07-11 07:23 atrol Assigned To => atrol
2019-07-11 07:23 atrol Status new => resolved
2019-07-11 07:23 atrol Resolution open => duplicate
2019-07-11 07:23 atrol Relationship added duplicate of 0022817