View Issue Details

IDProjectCategoryView StatusLast Update
0025998mantisbtdocumentationpublic2020-05-23 19:36
Reporterdregad Assigned Tovboctor  
PrioritynormalSeveritymajorReproducibilityN/A
Status resolvedResolutionfixed 
Target Version2.25.0Fixed in Version2.25.0 
Summary0025998: REST API documentation
Description

Currently, the REST API's documentation is hosted externally at https://documenter.getpostman.com/view/29959/mantis-bug-tracker-rest-api/7Lt6zkP

The source is not part of the MantisBT repository, and generally not available to the team since currently @vboctor is the only person having access to the Postman account.

We need to

  1. reference the documentation on http://mantisbt.org/documentation.php
  2. define a process so the team (and possibly contributors, if possible) can update and publish the documentation
Additional Information

Record of a Gitter discussion on the subject

@dregad April 17, 2019 9:40 AM

@vboctor As I was reviewing PR 1506, I thought that this change should be reflected in documentation. That's when I realized that the REST API docs are not in the repository. What is the process to maintain / update that ?

@vboctor April 18, 2019 9:22 AM:

For the API documentation I do this via Postman and it may rely on my account being a paid one. I’ll explore options.

TagsNo tags attached.

Relationships

related to 0026982 new mantisbt REST API documentation not discoverable via https://explore.postman.com/ 

Activities

dregad

dregad

2019-08-14 09:55

developer   ~0062568

@vboctor I'm assigning this to you, as you're currently the only one who can take action on point 2.

If sharing Postman account turns out not to be an option, maybe we can consider other alternatives for REST API docs ?
Reference: https://pronovix.com/blog/free-and-open-source-api-documentation-tools

vboctor

vboctor

2019-08-20 02:13

manager   ~0062612

PR: https://github.com/mantisbt/mantisbt/pull/1546

Related Changesets

MantisBT: master 8bdbfa7d

2019-08-20 02:11:41

vboctor

Details Diff
Add Postman collection and environment

Fixes 0025998
Affected Issues
0025998
add - api/rest/api.postman_collection.json Diff File
add - api/rest/env.postman_environment.json Diff File

MantisBT: master 9efcff25

2020-05-10 14:09:01

vboctor

Details Diff
Add REST API section in Developer manual

Fixes 0025998
Affected Issues
0025998
add - docbook/Developers_Guide/en-US/Api_Rest.xml Diff File
mod - docbook/Developers_Guide/en-US/Developers_Guide.xml Diff File

Issue History

Date Modified Username Field Change
2019-08-14 09:48 dregad New Issue
2019-08-14 09:55 dregad Assigned To => dregad
2019-08-14 09:55 dregad Status new => assigned
2019-08-14 09:55 dregad Note Added: 0062568
2019-08-14 09:55 dregad Assigned To dregad => vboctor
2019-08-20 02:13 vboctor Note Added: 0062612
2019-08-20 06:11 binghuo365 File Added: TIM图片20190102204342.jpg
2019-08-20 06:13 binghuo365 File Added: image.png
2019-08-20 08:25 atrol File Deleted: TIM图片20190102204342.jpg
2019-08-20 08:25 atrol File Deleted: image.png
2020-05-23 17:36 vboctor Changeset attached => MantisBT master 8bdbfa7d
2020-05-23 17:36 vboctor Changeset attached => MantisBT master 9efcff25
2020-05-23 17:36 vboctor Status assigned => resolved
2020-05-23 17:36 vboctor Resolution open => fixed
2020-05-23 17:36 vboctor Fixed in Version => 2.25.0
2020-05-23 18:11 atrol Target Version => 2.25.0
2020-05-23 19:36 dregad Relationship added related to 0026982