View Issue Details

IDProjectCategoryView StatusLast Update
0026098mantisbtdocumentationpublic2019-12-09 04:32
Reporterdregad Assigned Todregad  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version2.23.0 
Target Version2.23.0Fixed in Version2.23.0 
Summary0026098: Update ERD diagram to reflect new field in bug_file table
Description

bugnote_id field was added to bug_file table as part of implementation of 0021733

TagsNo tags attached.

Relationships

related to 0021733 closedvboctor Attachments should be linkable to notes in db 

Activities

atrol

atrol

2019-08-29 14:41

developer   ~0062688

@dregad not sure you are aware of 0021799

dregad

dregad

2019-08-29 18:15

developer   ~0062689

Missed that one. Thanks, I'll check.

Related Changesets

MantisBT: master be09c128

2019-08-29 07:12:54

dregad

Details Diff
Update ERD diagram to schema 210

- Reflect changes since schema 209
- Updated image for Developer's guide
- Improve README file
- Update MySQLWorkbench version
- Update download link
- Add instructions to update latest PDF symlink
- Minor formatting adjustments

Fixes 0026098
Affected Issues
0026098
mod - docbook/Developers_Guide/en-US/images/erd.png Diff File
mod - docbook/erd/README.md Diff File
mod - docbook/erd/mantisbt.mwb Diff File

MantisBT: master 80b88ea2

2019-08-30 11:35:53

dregad

Details Diff
Fix incorrect column data types in ERD

The reference database that was used to build the original diagram
(MySQL Workbench reverse engineering feature) was not a fresh install.
As a result, there were discrepancies in some data types (e.g. columns
linked to enums were VARCHAR instead of SMALLINT).

Fixes 0021799

Also added missing relationship between _bugnote_ and _bug_file_ tables
(Issue 0026098).
Affected Issues
0021799, 0026098
mod - docbook/Developers_Guide/en-US/images/erd.png Diff File
mod - docbook/erd/mantisbt.mwb Diff File
add - docbook/erd/mantisbt_2.23.0_210_erd_r2.pdf Diff File

Issue History

Date Modified Username Field Change
2019-08-29 07:20 dregad New Issue
2019-08-29 07:20 dregad Status new => assigned
2019-08-29 07:20 dregad Assigned To => dregad
2019-08-29 07:20 dregad Changeset attached => MantisBT master be09c128
2019-08-29 07:20 dregad Status assigned => resolved
2019-08-29 07:20 dregad Resolution open => fixed
2019-08-29 07:20 dregad Fixed in Version => 2.23.0
2019-08-29 07:21 dregad Relationship added related to 0021733
2019-08-29 14:41 atrol Note Added: 0062688
2019-08-29 18:15 dregad Note Added: 0062689
2019-08-30 11:38 dregad Changeset attached => MantisBT master 80b88ea2
2019-12-09 04:32 vboctor Status resolved => closed