View Issue Details

IDProjectCategoryView StatusLast Update
0026141mantisbtcustom fieldspublic2019-09-27 05:46
Reportercproensa Assigned Tocproensa  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.23.0 
Target Version2.23.0Fixed in Version2.23.0 
Summary0026141: Use max length property of custom field in inputs
Description
  • When a "string" type custom field has a max length defined, we should use that for the rendered input in the form, to limit the width of the input.
    Currently, the maximum length is used for maxlength input property, but a hardcoded size="80" is always used.

  • Limit the textareainput length when the custom field, of type "text", has a max length defined.

TagsNo tags attached.

Relationships

related to 0010370 feedback Max field length not respected. 

Activities

dregad

dregad

2019-09-17 08:24

developer   ~0062850

See related 0010370 - the issue there is slightly different because the user is expecting to be able to store CF's longer than 255 chars, but part of the problem would be fixed by setting the field's maxlength (and also making sure that field size can't be set to a value higher than the underlying DB field.

cproensa

cproensa

2019-09-22 10:17

developer   ~0062884

https://github.com/mantisbt/mantisbt/pull/1569

Related Changesets

MantisBT: master 4c52fa00

2019-09-22 00:21:21

cproensa


Committer: dregad Details Diff
Use max length property of custom field in inputs

When a string, or text, type custom field has a max length defined, we
should use that for the rendered input in the form, to limit the width
of the input.

Fixes: 0026141
Affected Issues
0026141
mod - core/cfdefs/cfdef_standard.php Diff File

Issue History

Date Modified Username Field Change
2019-09-14 19:27 cproensa New Issue
2019-09-17 08:23 dregad Relationship added related to 0010370
2019-09-17 08:24 dregad Note Added: 0062850
2019-09-22 05:58 cproensa Description Updated View Revisions
2019-09-22 06:02 cproensa Summary Use max size property of custom field in inputs => Use max length property of custom field in inputs
2019-09-22 06:02 cproensa Description Updated View Revisions
2019-09-22 10:17 cproensa Assigned To => cproensa
2019-09-22 10:17 cproensa Status new => assigned
2019-09-22 10:17 cproensa Note Added: 0062884
2019-09-27 05:38 dregad Changeset attached => MantisBT master 4c52fa00
2019-09-27 05:38 cproensa Status assigned => resolved
2019-09-27 05:38 cproensa Resolution open => fixed
2019-09-27 05:38 cproensa Fixed in Version => 2.23.0
2019-09-27 05:46 atrol Target Version => 2.23.0