View Issue Details

IDProjectCategoryView StatusLast Update
0026470mantisbtlocalizationpublic2020-03-15 15:23
Reporterobmsch Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.23.0 
Target Version2.23.1Fixed in Version2.23.1 
Summary0026470: Issue values on bug view page are not localized.
Description

This is new with 2.23. Ok til 2.22.

TagsNo tags attached.

Relationships

related to 0025902 closedvboctor Implement IssueViewPageCommand to separate logic from rendering of issue view page 

Activities

obmsch

obmsch

2019-12-13 09:45

reporter   ~0063271

view_2.22.png (18,261 bytes)   
view_2.22.png (18,261 bytes)   
view_2.23.png (17,685 bytes)   
view_2.23.png (17,685 bytes)   
atrol

atrol

2019-12-13 09:54

developer   ~0063272

Last edited: 2019-12-13 10:42

View 2 revisions

I am not able to reproduce, so this might be caused by your customization.
Are you able to reproduce on https://www.mantisbt.org/bugs ?

obmsch

obmsch

2019-12-13 10:25

reporter   ~0063273

@atrol This is with FF 71.0(64) on matisbt.org

mantis_org_2-23.png (17,424 bytes)   
mantis_org_2-23.png (17,424 bytes)   
atrol

atrol

2019-12-13 10:41

developer   ~0063274

I am able to reproduce using language settings auto.
As a workaround use language settings german.

atrol

atrol

2019-12-13 11:16

developer   ~0063275

Caused by this commit

atrol

atrol

2019-12-13 11:24

developer   ~0063276

@obmsch maybe the better workaround for you is to set $g_fallback_language = 'german'; in config_inc.php as this affects all users.

obmsch

obmsch

2019-12-13 15:11

reporter   ~0063277

@atrol thanks for your suggestions.

Just for the record, as others might be interested:
$g_fallback_language = 'german'; works $g_default_language = 'german'; doesn't.

Checked with some other languages and got the expected results. So this might be a workaround til the regression gets fixed.

atrol

atrol

2019-12-13 16:13

developer   ~0063279

@vboctor this PR fixes the issue https://github.com/mantisbt/mantisbt/pull/1595
But I am not sure if this is questionable / introduces unwanted side effects for the SOAP / REST API.
Sorry, no time to have a deeper look.

Related Changesets

MantisBT: master-2.23 0ebb36f5

2019-12-13 16:03:17

atrol

Details Diff
Fix auto language regression in View Issue Details page

Fixes 0026470
Affected Issues
0026470
mod - api/soap/mc_api.php Diff File

Issue History

Date Modified Username Field Change
2019-12-13 09:44 obmsch New Issue
2019-12-13 09:45 obmsch Note Added: 0063271
2019-12-13 09:45 obmsch File Added: view_2.22.png
2019-12-13 09:45 obmsch File Added: view_2.23.png
2019-12-13 09:54 atrol Status new => feedback
2019-12-13 09:54 atrol Note Added: 0063272
2019-12-13 10:25 obmsch Note Added: 0063273
2019-12-13 10:25 obmsch File Added: mantis_org_2-23.png
2019-12-13 10:25 obmsch Status feedback => new
2019-12-13 10:41 atrol Status new => confirmed
2019-12-13 10:41 atrol Note Added: 0063274
2019-12-13 10:42 atrol Note Edited: 0063272 View Revisions
2019-12-13 11:16 atrol Note Added: 0063275
2019-12-13 11:16 atrol Assigned To => vboctor
2019-12-13 11:16 atrol Status confirmed => assigned
2019-12-13 11:24 atrol Note Added: 0063276
2019-12-13 15:11 obmsch Note Added: 0063277
2019-12-13 16:13 atrol Note Added: 0063279
2019-12-20 14:21 atrol Assigned To vboctor => atrol
2019-12-20 14:21 atrol Target Version => 2.23.1
2019-12-26 11:20 atrol Changeset attached => MantisBT master-2.23 0ebb36f5
2019-12-26 11:20 atrol Status assigned => resolved
2019-12-26 11:20 atrol Resolution open => fixed
2019-12-26 11:29 atrol Fixed in Version => 2.23.1
2020-01-20 16:55 atrol Relationship added related to 0025902
2020-03-15 15:23 vboctor Status resolved => closed