View Issue Details

IDProjectCategoryView StatusLast Update
0026630mantisbtattachmentspublic2020-02-09 07:05
Reporterpolzin Assigned Toatrol  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version2.23.0 
Summary0026630: No file upload possible, if config( 'default_bugnote_view_status' ) is not VS_PUBLIC
Description

There seems to be an unintended side effect of the private attachments, as bugnote_add_inc.php still contains the lines:

<pre>
$t_attach_style = ( $t_default_bugnote_view_status != VS_PUBLIC ) ? 'display: none;' : '';
?>
<tr id="bugnote-attach-files" style="<?php echo $t_attach_style ?>">
</pre>

As the change of the attach_style was removed, it is not possible to do file uploads, if default_bugnote_view_status is not VS_PUBLIC.

The $t_attach_style is not necessary any longer.

<pre>
?>
<tr id="bugnote-attach-files">
</pre>

TagsNo tags attached.

Relationships

duplicate of 0026627 closedatrol Add files with option "default_bugnote_view_status" set to VS_PRIVATE 

Activities

atrol

atrol

2020-01-28 02:00

developer   ~0063522

@polzin is this the same 0026627 ?

polzin

polzin

2020-01-28 04:34

reporter   ~0063525

Yes, sorry, I created a duplicate (although I tried to search for existing issues)

Issue History

Date Modified Username Field Change
2020-01-27 13:55 polzin New Issue
2020-01-28 02:00 atrol Status new => feedback
2020-01-28 02:00 atrol Note Added: 0063522
2020-01-28 04:34 polzin Note Added: 0063525
2020-01-28 04:34 polzin Status feedback => new
2020-01-28 04:39 dregad Assigned To => atrol
2020-01-28 04:39 dregad Status new => resolved
2020-01-28 04:39 dregad Resolution open => duplicate
2020-01-28 04:39 dregad Relationship added duplicate of 0026627
2020-02-09 07:05 atrol Status resolved => closed