View Issue Details

IDProjectCategoryView StatusLast Update
0026728mantisbtattachmentspublic2020-03-10 17:23
Reporterkeessonnema Assigned Todregad  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version2.23.0 
Summary0026728: file_get_visible_attachments shows private attachments (uploaded with a private bugnote)
Description

In bug 0009802 the ability to add attachments to private notes was added, however file_get_visible_attachments still shows all attachments.
According to this function: Gets an array of attachments that are visible to the currently logged in user. Which is clearly not the case.

Steps To Reproduce

Call file_get_visible_attachments( $p_bug_id ) from PHP.

Additional Information

https://www.mantisbt.org/bugs/view.php?id=22323

TagsNo tags attached.

Relationships

duplicate of 0026631 closedvboctor file_get_visible_attachments shows private files that should be invisible to the user 

Activities

dregad

dregad

2020-02-21 06:40

developer   ~0063672

This issue has already been reported, see 0026631

Issue History

Date Modified Username Field Change
2020-02-21 04:13 keessonnema New Issue
2020-02-21 06:40 dregad Assigned To => dregad
2020-02-21 06:40 dregad Status new => resolved
2020-02-21 06:40 dregad Resolution open => duplicate
2020-02-21 06:40 dregad Note Added: 0063672
2020-02-21 06:40 dregad Relationship added duplicate of 0026631
2020-03-10 17:23 atrol Status resolved => closed