View Issue Details

IDProjectCategoryView StatusLast Update
0026735mantisbtinstallationpublic2020-03-10 17:23
ReporterJayEn84 Assigned Toatrol  
PrioritynormalSeveritytweakReproducibilitysometimes
Status closedResolutionduplicate 
Product Version2.23.0 
Summary0026735: Misleading wording for warning "register_argc_argv" in Check script
Description

The post-upgrade / post-installation documentation tells me to run admin/check/index.php. Doing so displays the following warning:


register_argc_argv php.ini directive is disabled
This directive should be disabled to increase performance (it only affects PHP in CLI mode).

The corresponding PHP code from admin/check/check_php_inc.php is the following:


check_print_test_warn_row(
'register_argc_argv php.ini directive is disabled',
!ini_get_bool( 'register_argc_argv' ),
array( false => 'This directive should be disabled to increase performance (it only affects PHP in CLI mode).' )
);

I find the wording of the warning misleading, or maybe it is even a false positive, because what I understand is that on my webserver, "register_argc_argv" is disabled, therefore I get a warning that it should be disabled. That does not make sense at all. Can someone explain me this warning / or provide a better wording / or fix this false positive?

TagsNo tags attached.

Relationships

duplicate of 0026590 new Wording of admin/check/index.php results could be clarified with a prefix 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-02-24 08:55 JayEn84 New Issue
2020-02-24 16:45 atrol Assigned To => atrol
2020-02-24 16:45 atrol Status new => resolved
2020-02-24 16:45 atrol Resolution open => duplicate
2020-02-24 16:45 atrol Relationship added duplicate of 0026590
2020-03-10 17:23 atrol Status resolved => closed