View Issue Details

IDProjectCategoryView StatusLast Update
0026750mantisbtcustom fieldspublic2020-03-15 07:01
Reporterchadmiss Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version2.23.0 
Summary0026750: multilist and checkbox customfields are listed in history without change
Description

when updating a bug, customfields of the type multilist and checkbox are listed in the bug histroy with the same value for old and new

problem ist the function cfdef_prepare_list_value_to_database that is called in custom_field_value_to_database() for these types of custom field. there are the pipes '|' added to the value and the comparison in history_log_event_direct() detects old and new value as different

tested in 2.23 and 2.21.1

TagsNo tags attached.

Relationships

duplicate of 0022408 assigneddregad Custom field's value logged as changed in history, when it wasn't changed 

Activities

chadmiss

chadmiss

2020-03-03 04:34

reporter   ~0063726

Last edited: 2020-03-03 04:36

View 2 revisions

copy of 3-year-old bug 0022408

Issue History

Date Modified Username Field Change
2020-02-27 04:51 chadmiss New Issue
2020-03-03 04:34 chadmiss Note Added: 0063726
2020-03-03 04:36 chadmiss Note Edited: 0063726 View Revisions
2020-03-03 04:59 atrol Assigned To => atrol
2020-03-03 04:59 atrol Status new => resolved
2020-03-03 04:59 atrol Resolution open => duplicate
2020-03-03 04:59 atrol Relationship added duplicate of 0022408
2020-03-15 07:01 atrol Status resolved => closed