View Issue Details

IDProjectCategoryView StatusLast Update
0026839mantisbtprintingpublic2020-04-03 01:49
Reporterbmason Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.22.2 
Target Version2.25.0Fixed in Version2.25.0 
Summary0026839: Viewer does not get Selection column in View Issues or Print Reports lists
Description

Users with Viewer access cannot see the Selection column in the View Issues list or the Print Reports screen, even though that column is included in their Manage Columns.

This seems to happen regardless of the project selected.

Steps To Reproduce

Log in as a user with global access level of Viewer.
In My Account, open Manage Columns.
Verify that selection is the first column listed for View Issues Columns and for Print Issues Columns.
Now click View Issues and adjust filter so that some issues are listed.
Notice there are no selection boxes in the selection column.
Click Print Reports.
Notice there are no selection boxes in the selection column.

TagsNo tags attached.

Activities

atrol

atrol

2020-04-01 16:43

developer   ~0063814

Last edited: 2020-04-01 16:46

View 3 revisions

Now click View Issues and adjust filter so that some issues are listed.
Notice there are no selection boxes in the selection column.

I assume there is also no drop down at the bottom to select an action. Right?
If so, this is the reason that no checkboxes are displayed, as they are not needed in this case.

Click Print Reports.
Notice there are no selection boxes in the selection column.

This is a bug, as the checkboxes are needed for the Display selected only button.

bmason

bmason

2020-04-01 16:56

reporter   ~0063815

Yes, you are right. The fact that the selection boxes are missing in the View Issues list is okay because a Viewer can't do anything on that screen anyway.

But the fact that they are missing from the Print Reports screen is definitely a problem because the Viewer will not be able to print or export the exact bugs they want.

atrol

atrol

2020-04-01 17:07

developer   ~0063816

Last edited: 2020-04-01 17:08

View 2 revisions

PR https://github.com/mantisbt/mantisbt/pull/1644

@bmason, would be fine if you could confirm that the changes in the PR fix the issue.
For the changes see https://github.com/mantisbt/mantisbt/pull/1644/files

bmason

bmason

2020-04-01 17:16

reporter   ~0063817

Wow, that was fast!

I noticed the new line of code seems to be coming before a comment line that relates to the deleted line. You may wish to remove the comment if it is no longer valid.

My test system is not available at this moment because we are validating version 2.22.2 for our intended use. Will try to test the fix in the next couple of days.

atrol

atrol

2020-04-01 17:28

developer   ~0063818

You may wish to remove the comment if it is no longer valid.

The comment is still valid, it's a comment for the next line 1084

# check report_bug_threshold for the actions "copy" or "move" into any other project
access_has_any_project_level( 'report_bug_threshold' ) 

Related Changesets

MantisBT: master 85d66844

2020-04-01 16:56:35

atrol

Details Diff
Display always selection checkbox on print_all_bug_page page

Fixes 0026839
Affected Issues
0026839
mod - core/columns_api.php Diff File

Issue History

Date Modified Username Field Change
2020-04-01 14:15 bmason New Issue
2020-04-01 16:43 atrol Status new => feedback
2020-04-01 16:43 atrol Note Added: 0063814
2020-04-01 16:43 atrol Note Edited: 0063814 View Revisions
2020-04-01 16:46 atrol Note Edited: 0063814 View Revisions
2020-04-01 16:56 bmason Note Added: 0063815
2020-04-01 16:56 bmason Status feedback => new
2020-04-01 17:05 atrol Assigned To => atrol
2020-04-01 17:05 atrol Status new => assigned
2020-04-01 17:07 atrol Target Version => 2.25.0
2020-04-01 17:07 atrol Note Added: 0063816
2020-04-01 17:08 atrol Note Edited: 0063816 View Revisions
2020-04-01 17:16 bmason Note Added: 0063817
2020-04-01 17:28 atrol Note Added: 0063818
2020-04-03 01:49 atrol Changeset attached => MantisBT master 85d66844
2020-04-03 01:49 atrol Status assigned => resolved
2020-04-03 01:49 atrol Resolution open => fixed
2020-04-03 01:49 atrol Fixed in Version => 2.25.0