View Issue Details

IDProjectCategoryView StatusLast Update
0029462mantisbtinstallationpublic2022-01-23 04:53
Reportergerong Assigned Todregad  
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindows 10OSWINDOWSOS Version10
Product Version2.25.2 
Target Version2.25.3Fixed in Version2.25.3 
Summary0029462: Unable to install
Description

WAMP stack: Bitnami v.8.1.1
OS: Windows 10 latest patch
DB: maria db v.10.4.22
PHP: v. 8.1.1
Apache: v.2.4.52

BLOCK: Installation fails with no obvious error.
Apache error log reports a lot of notices like below and then installation page reports "INTERNAL ERROR":

PHP Deprecated: Return type of ADODB_Iterator_empty::current() should either be compatible with Iterator::current(): mixed, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in C:\Bitnami\wampstack-8.1.1-0\apache2\htdocs\mantisbt\vendor\adodb\adodb-php\adodb.inc.php on line 3174

Question: Is Mantis BT compatible with latest PHP version 8.1.1?

Steps To Reproduce

try to execute : C:\Bitnami\wampstack-8.1.1-0\apache2\htdocs\mantisbt\admin\install.php script

Additional Information

Bitnami installation was 100% successful and WAMP stack is working flawlessly with a demo test PHP page.

TagsPHP 8.1

Activities

atrol

atrol

2022-01-10 14:23

developer   ~0066157

This is a known issue in ADOdb that is fixed in version 5.22.0 (not released yet) https://github.com/ADOdb/ADOdb/issues/771
@dregad is there a planned release date for it?

dregad

dregad

2022-01-11 02:27

developer   ~0066158

is there a planned release date for (ADOdb version 5.22.0)

No fixed date, but should be in the next few days (I'm working on it).

That said, we are still on 5.20, and have not yet upgraded to 5.21, because that introduces issues with MSSQL (0028015:0065205) and PostgreSQL (see 0028069), so we may need a 5.20.x patch for this.

dregad

dregad

2022-01-22 20:14

developer   ~0066185

Fixed in ADOdb 5.20.21 - see MantisBT master-2.25 8db84042

Related Changesets

MantisBT: master-2.25 8db84042

2022-01-22 19:31:03

dregad

Details Diff
Bump adodb/adodb-php from 5.20.20 to 5.20.21

Fixes #29485
Affected Issues
0029462
mod - composer.json Diff File
mod - composer.lock Diff File