View Issue Details

IDProjectCategoryView StatusLast Update
0029511mantisbtinstallationpublic2022-05-12 03:25
Reporterarielmn Assigned Todregad  
PriorityimmediateSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindows Server 2019 StandardOS Version1809
Product Version2.25.2 
Fixed in Version2.26.0 
Summary0029511: MSSQL blocking error during installation.
Description

I got the blocking error: "Attempting to access array offset on value of type bool" originating from function DefaultConstraintname in datadict-mssqlnative.inc.php file (line 159), which prevents me from installing the application.
It creates the database with some tables (not sure if all of them) and it keeps me stuck on the install page.

Steps To Reproduce
  • Install Apache 2.4.39 (x86)

  • Install PHP 8.0.15 (x86)

  • Copy SQLSRV Drivers (x86) php_pdo_sqlsrv_80_ts.dll and php_sqlsrv_80_ts.dll into php/ext folder

  • Edit php/php.ini file adding this externals:

    extension=pdo_sqlsrv_80_ts
    extension=sqlsrv_80_ts
    extension=mbstring
  • Edit Apache24/conf/httpd.conf file adding this:

    <IfModule mime_module>
    # PHP 8
    LoadModule php_module "C:/php8/php8apache2_4.dll"
    PHPIniDir "C:/php8"
    # (...)
    </IfModule>
    <Directory "C:/mantisbt/">
    AllowOverride None
    Options None
    Require all granted
    </Directory>
    <IfModule alias_module>
    Alias /mantisbt/ "C:/mantisbt/mantisbt-2.25.2/"
    # (...)
    </IfModule>
  • Test SQLSRV is running properly (OPTIONAL):

  • Adding php folder to the system path and running this line "php -S localhost:8000" from cmd. All good if no errors.

  • Check if SQLSRV is Enabled by creating a file C:/mantisbt/mantisbt-2.25.2/info.php with this line "<?php phpinfo(); ?>" and visiting http://127.0.0.1/mantisbt/info.php after configure Apache with previous step. All good if SQLSRV is in the list and is enabled.

  • Config and try to install MantisBT <- Leads to error (see images for details)

EDIT (dregad) added markdown around code blocks

Additional Information
TagsNo tags attached.
Attached Files
status.png (33,328 bytes)   
status.png (33,328 bytes)   
config.png (60,476 bytes)   
config.png (60,476 bytes)   
error.png (30,196 bytes)   
error.png (30,196 bytes)   
function.png (42,570 bytes)   
function.png (42,570 bytes)   

Relationships

has duplicate 0028028 closeddregad Installer throws PHP warning on MS SQL Server 
child of 0028015 resolveddregad Update ADOdb to 5.21.4 

Activities

arielmn

arielmn

2022-01-27 06:51

reporter   ~0066193

Last edited: 2022-01-27 06:55

I don't know if it will be useful but here it's the output of the query "SELECT name FROM sys.default_constraints" without the WHERE condition in the created BUG_TRACKER database.

arielmn

arielmn

2022-01-27 08:13

reporter   ~0066195

Output file.

output.txt (5,282 bytes)   
DFmantis_cufield00200768
DF__mantis_ususern00DF2177
DFmantis_cuproje01142BA1
DFmantis_usrealn01D345B0
DF__mantis_cuseque02084FDA
DFmantis_usemail02C769E9
DFmantis_uspassw03BB8E22
DF__mantis_cufield04E4BC85
DFmantis_cubug_i05D8E0BE
DFmantis_usenabl0697FACD
DFmantis_cuvalue06CD04F7
DFmantis_usprote078C1F06
DF__mantis_usacces0880433F
DFmantis_uslogin09746778
DFmantis_cusname09A971A2
DF__mantis_uslost_0A688BB1
DF__mantis_custype0A9D95DB
DFmantis_usfaile0B5CAFEA
DFmantis_uscooki0C50D423
DF__mantis_cudefau0C85DE4D
DFmantis_cuvalid0D7A0286
DFmantis_cuacces0E6E26BF
DF__mantis_ememail0F2D40CE
DFmantis_cuacces0F624AF8
DFmantis_emsubje10216507
DF__mantis_culengt10566F31
DFmantis_culengt114A936A
DFmantis_butarge1209AD79
DF__mantis_cuadvan123EB7A3
DFmantis_butime_12FDD1B2
DFmantis_curequi1332DBDC
DFmantis_curequi14270015
DFmantis_cudispl151B244E
DF__mantis_tauser_15DA3E5D
DF__mantis_cudispl160F4887
DFmantis_tagname16CE6296
DFmantis_curequi17036CC0
DF__mantis_cudispl17F790F9
DFmantis_cudispl18EBB532
DFmantis_curequi19DFD96B
DF__mantis_bubug_i1B9317B3
DFmantis_butag_i1C873BEC
DFmantis_fiuser_1CBC4616
DF__mantis_buuser_1D7B6025
DF__mantis_fiproje1DB06A4F
DFmantis_fiis_pu1EA48E88
DFmantis_filname1F98B2C1
DFmantis_plenabl214BF109
DFmantis_user_pref_table__redirect_delay50edffdf
DFmantis_neproje22751F6C
DF__mantis_neposte236943A5
DFmantis_nedate_245D67DE
DFmantis_caproje251C81ED
DFmantis_nelast_25518C17
DFmantis_causer_2610A626
DF__mantis_neview_2645B050
DF__mantis_catname2704CA5F
DFmantis_neannou2739D489
DFmantis_castatu27F8EE98
DF__mantis_neheadl282DF8C2
DFmantis_bucateg28ED12D1
DFmantis_prcateg29E1370A
DF__mantis_prinher2AD55B43
DFmantis_prinher2BC97F7C
DFmantis_plprote2CBDA3B5
DF__mantis_plprior2DB1C7EE
DFmantis_probsol2EA5EC27
DFmantis_prproje2FCF1A8A
DF__mantis_cufilte308E3499
DFmantis_prtitle30C33EC3
DFmantis_prdescr31B762FC
DF__mantis_prdiskf32AB8735
DFmantis_bubugno336AA144
DFmantis_prfilen339FAB6E
DF__mantis_butimes345EC57D
DFmantis_prfolde3493CFA7
DFmantis_bu_date3552E9B6
DFmantis_prfiles3587F3E0
DF__mantis_budue_d36470DEF
DFmantis_prfile_367C1819
DFmantis_coproje36B12243
DFmantis_bulast_373B3228
DFmantis_couser_37A5467C
DF__mantis_bulast_382F5661
DF__mantis_coacces38996AB5
DFmantis_budate_39237A9A
DFmantis_contype398D8EEE
DFmantis_budate_3A179ED3
DFmantis_prdate_3B0BC30C
DF__mantis_proname3B40CD36
DFmantis_budate_3BFFE745
DFmantis_prstatu3C34F16F
DFmantis_bubug_i3C69FB99
DFmantis_uslast_3CF40B7E
DF__mantis_prenabl3D2915A8
DFmantis_butitle3D5E1FD2
DFmantis_us_date3DE82FB7
DFmantis_pr_view3E1D39E1
DFmantis_budescr3E52440B
DF__mantis_emsubmi3EDC53F0
DFmantis_pracces3F115E1A
DFmantis_budiskf3F466844
DF__mantis_tadate_3FD07829
DF__mantis_prfile_40058253
DF__mantis_bufilen403A8C7D
DFmantis_tadate_40C49C62
DFmantis_bufolde412EB0B6
DFmantis_budate_41B8C09B
DFmantis_bufiles4222D4EF
DFmantis_totimes42ACE4D4
DFmantis_prproje42E1EEFE
DF__mantis_bufile_4316F928
DF__mantis_toexpir43A1090D
DFmantis_pruser_43D61337
DFmantis_pracces44CA3770
DFmantis_buuser_46E78A0C
DFmantis_prproje47A6A41B
DFmantis_bubug_i47DBAE45
DFmantis_prversi489AC854
DFmantis_prdate_498EEC8D
DFmantis_prrelea4A8310C6
DFmantis_bugtype4CA06362
DFmantis_sp__bug_i4D5F7D71
DFmantis_sp_user4E53A1AA
DFmantis_spamoun4F47C5E3
DF__mantis_buuser_4F7CD00D
DF__mantis_spologo503BEA1C
DFmantis_bubug_i5070F446
DFmantis_sponurl51300E55
DFmantis_spopaid5224328E
DFmantis_sp_date531856C7
DFmantis_busourc534D60F1
DF__mantis_splast_540C7B00
DF__mantis_budesti5441852A
DFmantis_burelat5535A963
DFmantis_buproje5812160E
DF__mantis_ususer_58D1301D
DF__mantis_burepor59063A47
DFmantis_usproje59C55456
DFmantis_buhandl59FA5E80
DF__mantis_usdefau5AB9788F
DFmantis_budupli5AEE82B9
DFmantis_usdefau5BAD9CC8
DF__mantis_buprior5BE2A6F2
DFmantis_usadvan5CA1C101
DFmantis_busever5CD6CB2B
DF__mantis_usadvan5D95E53A
DFmantis_burepro5DCAEF64
DFmantis_usadvan5E8A0973
DF__mantis_bustatu5EBF139D
DFmantis_usrefre5F7E2DAC
DFmantis_buresol5FB337D6
DF__mantis_buproje60A75C0F
DFmantis_usbugno6166761E
DFmantis_usemail625A9A57
DF__mantis_usemail634EBE90
DFmantis_usemail6442E2C9
DFmantisbugeta6477ECF3
DFmantis_usemail65370702
DFmantis_bu__bug_t656C112C
DFmantis_usemail662B2B3B
DFmantis_bug_tos66603565
DFmantis_usemail671F4F74
DFmantis_buos_bu6754599E
DFmantis_usemail681373AD
DFmantis_buplatf68487DD7
DFmantis_usemail690797E6
DF__mantis_buversi693CA210
DFmantis_usemail69FBBC1F
DFmantis_bufixed6A30C649
DF__mantis_usemail6AEFE058
DFmantis_bubuild6B24EA82
DFmantis_usemail6BE40491
DF__mantis_buprofi6C190EBB
DFmantis_usemail6CD828CA
DFmantis_bu_view6D0D32F4
DFmantis_usemail6DCC4D03
DF__mantis_busumma6E01572D
DFmantis_usemail6EC0713C
DFmantis_buspons6EF57B66
DF__mantis_usemail6FB49575
DFmantis_bustick6FE99F9F
DFmantis_usemail70A8B9AE
DF__mantis_usemail719CDDE7
DFmantis_usemail72910220
DFmantis_usemail73852659
DF__mantis_uslangu74794A92
DFmantis_bubug_i74AE54BC
DFmantis_burepor75A278F5
DFmantis_bubugno76969D2E
DFmantis_us_user7755B73D
DFmantis_bu_view778AC167
DFmantis_bu_note7A672E12
DFmantis_us_user7B264821
DFmantis_bu_note7B5B524B
DFmantis_usplatf7C1A6C5A
DFmantisuseros7D0E9093
DFmantis_usos_bu__7E02B4CC
output.txt (5,282 bytes)   
obmsch

obmsch

2022-01-27 12:59

reporter   ~0066196

Known problem with php >=7.4 and ADOdb 5.20 (>=5.20.8). Due to serious regressions with mssql and postgres on ADOdb 5.21, MantisBT is still on ADOdb 5.20.
At least the mssql ones (including yours) are fixed in ADOdb 5.21.1, don't know about postgres.
So you have to either wait for the ADOdb bump and a MantisBT release with it, or you might try the following:

1) Download the latest 5.21 release from https://github.com/ADOdb/ADOdb/releases
2) Rename "(MantisBT)\vendor\adodb\adodb-php" to "(MantisBT)\vendor\adodb\adodb-php.org"
3) Create "(MantisBT)\vendor\adodb\adodb-php"
4) Unzip the content of the folder "ADOdb-5.21.4" from the download into "(MantisBT)\vendor\adodb\adodb-php"
Check if "(MantisBT)\vendor\adodb\adodb-php" and "(MantisBT)\vendor\adodb\adodb-php.org" are structurally equal
5) Make sure, you have a clean state. Drop/Empty the database from your previous attempts (SSMS)
6) Run the MantisBT installation
7) Delete "(MantisBT)\vendor\adodb\adodb-php"
8) Rename "(MantisBT)\vendor\adodb\adodb-php.org" to "(MantisBT)\vendor\adodb\adodb-php"

Martin

dregad

dregad

2022-01-28 06:13

developer   ~0066204

Thanks @obmsch for responding. This is indeed caused by ADOdb, so I linked 0028015 which tracks implementation of 5.21 in a future release of MantisBT.

dregad

dregad

2022-05-11 04:03

developer   ~0066558

Last edited: 2022-05-11 04:06

As far as I can tell, the problem is resolved in the ADOdb version we're currently bundling (5.21.4).

For the record, upstream issue -> https://github.com/ADOdb/ADOdb/issues/696