View Issue Details

IDProjectCategoryView StatusLast Update
0033342mantisbtbugtrackerpublic2024-02-19 17:19
Reporterpikachurus Assigned Todregad  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.26.0 
Summary0033342: cannot assign user to monitoring issues in public project (not assigned to him)
Description

in previous versions of MantisBT it was possible to assign registred user (with default access level 'reporter') monitoring issue in any public project.

with 2.26.0 it can't be done:
APPLICATION ERROR #31

Added user does not have sufficient access rights to monitor this issue.

Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.

Steps To Reproduce

1) create issue in public project
2) try adding user to monitoring this issue
3) application error #31

TagsNo tags attached.
Attached Files
image.png (22,143 bytes)   
image.png (22,143 bytes)   

Relationships

duplicate of 0033404 closedatrol Unable to grant user access to private issue by adding them as a monitoring user 
related to 0029454 closedatrol monitor receives no mails if he is not project member 
related to 0033348 resolveddregad Application error #31 (access rights to monitor issue) 

Activities

atrol

atrol

2023-11-23 15:44

developer   ~0068338

I was not able to reproduce.
Check on page "Manage" > "Configuration" > "Workflow Threshold" of the affected project if "Monitor an issue" is set for "reporter" access level.

dregad

dregad

2023-11-28 03:56

developer   ~0068346

I did not actually test to confirm, but the problem may have been introduced by the fix for 0029454. Make sure that the logged-in user who is attempting to add others to the monitoring list, has an access level >= monitor_add_others_bug_threshold

swaq

swaq

2023-11-28 06:41

reporter   ~0068348

This check didn't solve the problem.
Monitor an issue" is set for "reporter

dregad

dregad

2023-11-28 08:31

developer   ~0068349

Please do not confuse

  • monitor_bug_threshold (Access level needed to monitor bugs), and
  • monitor_add_others_bug_threshold (Access level needed to add other users to the list of users monitoring a bug).
pikachurus

pikachurus

2023-11-30 02:17

reporter   ~0068356

@atrol, I haven't changed these settings for a long time.

this issue came with 2.26.0 update.

tried to disable some external plugins (like this one https://github.com/mantisbt-plugins/MonProj), didn't help.

image-2.png (58,630 bytes)   
image-2.png (58,630 bytes)   
dregad

dregad

2023-11-30 03:10

developer   ~0068357

@pikachurus This is the setting that you need to check, as mentioned in 0033342:0068346

Make sure that the logged-in user who is attempting to add others to the monitoring list, has an access level >= monitor_add_others_bug_threshold

image-3.png (54,411 bytes)   
image-3.png (54,411 bytes)   
dregad

dregad

2023-12-01 11:28

developer   ~0068366

@pikachurus can you please confirm your setting for limit_view_unless_threshold (or the legacy limit_reporters, if you're still using that) ?

Considering the latest discussion in 0033348 (see 0033348:0068365) I'm now pretty sure that it's a duplicate.

pikachurus

pikachurus

2023-12-05 10:25

reporter   ~0068389

Last edited: 2023-12-05 10:26

@dregad, "limit_view_unless_threshold" sets to developer, but i've tried other options - nothing changes.

Considering the latest discussion in 0033348 (see 0033348:0068365) I'm now pretty sure that it's a duplicate.

I read this discussion and yeah, we deal with same problem :(

now we can't give access to monitor issue for specific user ("guest star") in project.

image-4.png (15,778 bytes)   
image-4.png (15,778 bytes)   
dregad

dregad

2024-02-19 17:19

developer   ~0068567

After analysis, this appears to be a duplicate of 0033404