View Issue Details

IDProjectCategoryView StatusLast Update
0003457mantisbtwebpagepublic2004-12-11 03:02
Reporterkaos Assigned Tovboctor  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Fixed in Version0.19.2 
Summary0003457: PHP5 issues
Description

I'm not sure if this is related to PHP5 or not, but it behaves quite weird.
The installation check returns all OK. So there's no problem with the db, and I can access the files from the browser.
But after visiting a mantis page (like admin/check.php), and then typing in another mantis page, nothing happens. Feels like it's some cookie that's locking the current page down.

Additional Information

Has mantis been tested on PHP5 yet?

TagsNo tags attached.

Relationships

related to 0004910 closedjlatour Upgrade ADODB from v3.50 to v4.54 
related to 0004911 closedvboctor db_prepare_string() doesn't work with mysqli 
parent of 0004745 closedvboctor PHP 5 array_merge() change causes errors 
has duplicate 0003631 closedgrangeway apache2 crash win php5b4 
child of 0004818 closedvboctor Mantis 0.19.2 release 

Activities

vboctor

vboctor

2003-12-11 22:46

manager   ~0004790

Which version of Mantis are you using? There was some issues with cookies that were fixed in 0.18.0aX. Hence, it is recommended to use 0.18.0 release.

I don't think any of the core development team tested Mantis on PHP5 yet.

kaos

kaos

2003-12-12 10:40

reporter   ~0004791

0.18.0-CVS, latest released version at the sf download page. (downloaded from sf.net yesterday).

epu

epu

2003-12-12 21:06

reporter   ~0004792

suggest documenting known working combos / non-working combos of php and mantis, adding warning to admin/check.php

dooshek

dooshek

2004-10-22 16:23

reporter   ~0008145

I'm preety sure that this bug has nothing to do with PHP5 - it's somehow bug in IE browser with inproper headers sent. I came to this solution long time ago and now I reminded this issue.

So this is, I think, related to no-cache headers sent to browser. I changed this in file ./core.php in line 102

header( 'Pragma: no-cache' );
header( 'Expires: Fri, 01 Jan 1999 00:00:00 GMT' );
header( 'Cache-Control: no-store, no-cache, must-revalidate' );
header( 'Cache-Control: post-check=0, pre-check=0', false );

to my tested headers:

header("Expires: Mon, 26 Jul 1997 05:00:00 GMT");
header("Last-Modified: " . gmdate("D, d M Y H:i:s") . " GMT");
header("Cache-Control: no-store, no-cache, must-revalidate");
header("Cache-Control: post-check=0, pre-check=0", false);
header("Cache-Control: private");
header("Pragma: no-cache");

and it works all great. Please consider this.

This bug is really annoying and is causing to load blank white page (you can't even see the source!) in IE (I tested it in IE 6). It affects random pages - I have'nt noticed any relations beetwen this "blanks".

I use Mantis 0.19.0 version.

vboctor

vboctor

2004-12-01 07:32

manager   ~0008473

I have been recently testing Mantis CVS (post 0.19.1) on Apache 2 / PHP 5.0.2. There was two main issues:

  1. ADODB needed an upgrade (this was the reason for the blank pages).
  2. There was a problem with mysqli_escape_string(). This was not enabling the users to login.

After fixing these issues, Mantis seems to be working without problems with PHP 5 and Apache 2. So I think 0.19.2 will officially support PHP 5 / Apache 2.

Issue History

Date Modified Username Field Change
2003-12-11 17:26 kaos New Issue
2003-12-11 22:46 vboctor Note Added: 0004790
2003-12-12 10:40 kaos Note Added: 0004791
2003-12-12 21:06 epu Note Added: 0004792
2004-07-23 17:28 grangeway Relationship added has duplicate 0003631
2004-07-24 08:35 grangeway Relationship added child of 0004181
2004-08-07 11:05 jlatour Status new => acknowledged
2004-10-22 07:16 thraxisp Relationship added parent of 0004745
2004-10-22 16:23 dooshek Note Added: 0008145
2004-12-01 07:26 vboctor Assigned To => vboctor
2004-12-01 07:27 vboctor Relationship added related to 0004910
2004-12-01 07:27 vboctor Relationship added related to 0004911
2004-12-01 07:28 vboctor Relationship deleted child of 0004181
2004-12-01 07:32 vboctor Status acknowledged => resolved
2004-12-01 07:32 vboctor Fixed in Version => 0.19.2
2004-12-01 07:32 vboctor Resolution open => fixed
2004-12-01 07:32 vboctor Note Added: 0008473
2004-12-01 07:32 vboctor Relationship added child of 0004818
2004-12-11 03:02 vboctor Status resolved => closed