View Issue Details
| ID | Project | Category | View Status | Date Submitted | Last Update |
|---|---|---|---|---|---|
| 0037443 | mantisbt | custom fields | public | 2026-10-08 04:40 | 2026-10-08 12:38 |
| Reporter | mb-kh | Assigned To | |||
| Priority | normal | Severity | crash | Reproducibility | always |
| Status | confirmed | Resolution | open | ||
| Product Version | 2.28.4 | ||||
| Target Version | 2.29.0 | ||||
| Summary | 0037443: Issue created via REST API with too long value for custom field fails in the middle of operation with 500 error | ||||
| Description | When you create an issue via REST API with a custom field (String type) and send value which is too long, more than 255 characters, it creates an issue but fails during 'INSERT INTO mantis_custom_field_string_table [...]'. Exception is thrown from database that data is too long for column 'value'. We were able to find a root cause quite quickly because we found deprecation message in logs: It fails in:
| ||||
| Steps To Reproduce |
| ||||
| Additional Information | PHP 8.4 | ||||
| Tags | No tags attached. | ||||
|
Behavior is confirmed, also on master branch (although there the deprecation warning has been fixed and an exception is thrown so the API does return HTTP 500 and not 200, but the issue still gets created without the custom field data). Problem also occurs when updating an issue (PATCH /issues/{id} endpoint), as well as from the GUI with a crafted POST request. |
|