View Issue Details

IDProjectCategoryView StatusLast Update
0003861mantisbtfeaturepublic2015-01-25 16:36
ReporternoideaAssigned Tovboctor 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0003861: NNTP support
Description

For accessability reasons, a Mantis-to-usenet interface can come in handy. You can check bug reports with standard news readers and with software like Outlook Express you can 'watch a conversation', meaning a quick overview for interesting reports

Additional Information

A text-only news-post is also readable on any OS. Having a read-only NNTP-server, readers can not post and Mantis does not have to take care of incoming info on other ways then now defined. Of course, only public reports should be posted to NNTP.
And yes, I do know Mantis has functionality to watch and track bug reports, but for me NNTP is another way to disclose the information.

TagsNo tags attached.

Activities

nuclearspike

nuclearspike

2004-05-24 16:37

reporter   ~0005575

Last edited: 2004-05-24 16:40

how important is user authentication and properly showing only what is available to that user? What I'm thinking of doing: create the news server app. In the config, you'd be able to set up different newsgroups, each one pointing to a different mysql server. Under each one, you'd have the projects, then category. so, let's say you have two databases you want to connect to and for some reason you're keeping your dev and support separate from each other.

development
support

then the server would automatically report

<dbalias>.<project>.<category>
development.supersalesman.mainscreen
development.supersalesman.reports
development.supersalesman.exports
development.inhousecallcenter.webreports
support.megababies40.plugins

etc

Within each news group it would show the bug description and bug notes would be placed under them, each new note would be shown as a child of the previous (since you cannot add a note in reply to a specific note).

It would be a Delphi NNTP server using the Indy 9.0 TidNNTPServer components -- which would make it a Windows app.

one problem i forsee is that if someone had edited a note or the description, the newsreader wouldn't know to re-request it.

edited on: 05-24-04 16:39

edited on: 05-24-04 16:40

deboutv

deboutv

2007-01-28 07:56

reporter   ~0013969

Hi,

I have written a plugin to post bugs notifications on a NNTP server.

http://deboutv.free.fr/mantis/plugin.php?plugin=MantisNNTP

vboctor

vboctor

2015-01-14 04:37

manager   ~0042152

I doubt we will ever get to implement this. If someone is interested, this can be implemented as a plugin.

Issue History

Date Modified Username Field Change
2004-05-19 17:16 noidea New Issue
2004-05-24 16:37 nuclearspike Note Added: 0005575
2004-05-24 16:39 nuclearspike Note Edited: 0005575
2004-05-24 16:40 nuclearspike Note Edited: 0005575
2007-01-28 07:56 deboutv Note Added: 0013969
2015-01-14 04:37 vboctor Assigned To => vboctor
2015-01-14 04:37 vboctor Status new => resolved
2015-01-14 04:37 vboctor Resolution open => fixed
2015-01-14 04:37 vboctor Note Added: 0042152
2015-01-14 04:37 vboctor Resolution fixed => won't fix
2015-01-25 16:36 atrol Status resolved => closed