View Issue Details

IDProjectCategoryView StatusLast Update
0003939mantisbtbugtrackerpublic2024-05-19 15:28
Reportermce128 Assigned Todregad  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
Summary0003939: Generated emails cause some email scanners to report false virus positives
Description

Some email scanners will report the emails generated by mantis to potentially contain a virus, and quarantine them.

Additional Information

This is due to declaring Content-Type and not declaring the Mime-Version.
Changing line 712 of email_api.php to: $t_headers .= 'Content-Type: text/plain; charset=' . lang_get( 'charset' ) . "\nMime-Version: 1.0\n";

Fixes the issue.

TagsNo tags attached.

Relationships

related to 0003900 closedvboctor Password reset email caught by 90% of current spam filters 

Activities

rombert

rombert

2011-07-26 08:45

reporter   ~0029298

Mime-Version still not set

dregad

dregad

2024-05-03 11:27

developer   ~0068883

The MIME-Version header should set by PHPMailer library, on any outgoing mail sent by MantisBT.

We are resolving this issue as "no change required", because it was reported against an old version of MantisBT which is no longer supported.

We recommend that you upgrade to the latest stable version [1]; if the problem persists after doing so, do not hesitate to reopen the issue.

[1] https://mantisbt.org/download.php