View Issue Details
| ID | Project | Category | View Status | Date Submitted | Last Update |
|---|---|---|---|---|---|
| 0004004 | mantisbt | bugtracker | public | 2004-07-05 01:05 | 2004-11-06 06:02 |
| Reporter | pengzhw | Assigned To | thraxisp | ||
| Priority | normal | Severity | minor | Reproducibility | always |
| Status | closed | Resolution | fixed | ||
| Fixed in Version | 0.19.1 | ||||
| Summary | 0004004: unable to download large size attachment | ||||
| Description | I'v successfully uploaded an attachment file of 9MB for a bug. But when viewing the bug/issue, I find that the file is unable to be downloaded to the browser side. No error messeage appears either inside Apache error_log or at the Mozilla web browser. However IE says the URL is unavailable when I try to download the attachment. | ||||
| Additional Information | PHP Version 4.2.2, Apache 1.3.27,Red Hat Linux 7.3 config_inc.php: Btw, I'v checked the md5sum to make sure the attachement file, a Microsoft Word file, is correctly uploaded to the server. | ||||
| Tags | No tags attached. | ||||
| Attached Files | file_download.php.patch (479 bytes)
--- file_download.php.rev.1.25.4.1 2004-08-13 22:54:35.000000000 +0800
+++ file_download.php 2004-08-13 22:54:06.000000000 +0800
@@ -69,6 +69,8 @@
header( 'Content-Length: ' . $v_filesize );
header( 'Content-Disposition: filename=' . file_get_display_name( $v_filename ) );
header( 'Content-Description: Download Data' );
+ header( 'Pragma: no-cache' );
+ header( 'Expires: 0' );
# dump file content to the connection.
switch ( config_get( 'file_upload_method' ) ) {
| ||||
|
P.S.: I am using mantis 0.18.3, and log_errors in php.ini is turned on. |
|
|
I'v modified file_download.php to fix the problem. The attached patch file is against: The modified file is also available. edited on: 08-13-04 10:14 |
|
|
At first I had a problem uploading files larger than 1MB, which I resolved with "set-variable = max_allowed_packet=2M" in mysql config file (my.cnf). |
|
|
I have the same problem with And I did the same thing as pengzhw ("set-variable = max_allowed_packet=5M" in mysql config file) to be able to upload such files. Mandrake 9.2 |
|
|
Fixed in CVS |
|