View Issue Details

IDProjectCategoryView StatusLast Update
0004305mantisbtchange logpublic2008-07-31 17:39
Reporterjwolfgarten Assigned Togiallu  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
Summary0004305: Make changelog configurable
Description

So that I can configure, if

  • ID
  • Developer
  • Reporter

is shown. Moreover it would be nice, if there is another view of the changelog:

ID: [Category]
Bugtext
Bugtext line 2 and so on

TagsNo tags attached.

Relationships

related to 0004268 new Changelog should have sorting options 
related to 0004306 acknowledged Make changelog exportable 
child of 0004181 closed Features in Mantis 1.1 release 

Activities

vboctor

vboctor

2004-08-11 03:41

manager   ~0006928

This can already be done by overriding the custom function that determines the format for the changlog entries. To do that create custom_functions_inc.php in the mantis main directory and implement the following:

<pre>

--------------------

# Prints one entry in the changelog.
function custom_function_override_changelog_print_issue( $p_issue_id ) {
    $t_bug = bug_get( $p_issue_id );
    echo '- ', string_process_bug_link( '#' . $p_issue_id ), ': <b>[', $t_bug->category, ']</b> ', string_display( $t_bug->summary ), ' (', user_get_name( $t_bug->handler_id ), ')<br />';
}

</pre>

Note that you get the issue id as a parameter, hence, you can retrieve any related information and echo it in the required format.

Let me know if this covers what you need.

jwolfgarten

jwolfgarten

2004-08-11 03:48

reporter   ~0006929

Thank you, I will test it as soon as possible. Maybe you could make it configurable via a dropdown like the filters... That way you can choose between different views.

vboctor

vboctor

2004-08-11 03:56

manager   ~0006931

The drop down will specify which format to use, however, you will still need to override these to output the entries based on the selected format.

jwolfgarten

jwolfgarten

2004-08-11 04:23

reporter   ~0006933

I tried it, but the following error appeared:

function custom_function_override_changelog_print_issue( $p_issue_id ) { $t_bug = bug_get( $p_issue_id ); echo '- ', string_process_bug_link( '#' . $p_issue_id ), ': [', $t_bug->category, '] ', string_display( $t_bug->summary ), ' (', user_get_name( $t_bug->handler_id ), ')'; }

SYSTEM WARNING: Cannot modify header information - headers already sent by (output started at /share/htdocs/mantis/custom_functions_inc.php:5)

SYSTEM WARNING: Cannot modify header information - headers already sent by (output started at /share/htdocs/mantis/custom_functions_inc.php:5)

SYSTEM WARNING: Cannot modify header information - headers already sent by (output started at /share/htdocs/mantis/custom_functions_inc.php:5)

SYSTEM WARNING: Cannot modify header information - headers already sent by (output started at /share/htdocs/mantis/custom_functions_inc.php:5)

thraxisp

thraxisp

2004-08-11 05:56

reporter   ~0006937

Thr custom_functions_inc file is a php file. It needs a "<?php" at the beginning and "?>" at the end.

jwolfgarten

jwolfgarten

2004-08-11 06:13

reporter   ~0006938

Sorry, some kind of sleeping today :-) Ok, that works fine. Do you think it´s possible to dropdown it like the filters?

DGtlRift

DGtlRift

2004-08-11 07:00

reporter   ~0006939

Last edited: 2004-08-11 07:02

Since this is on the topic of improving the Changelog, I think this is somewhat related to http://bugs.mantisbt.org/bug_view_page.php?bug_id=0004218

edited on: 08-11-04 07:02

Matt_wc

Matt_wc

2004-11-23 19:56

reporter   ~0008419

A csv export of the change log would be great.

Fields being ID, Catagory, Description, User

  • 0004764: [other] Url detection issue (grangeway)
giallu

giallu

2008-04-22 04:58

reporter   ~0017652

I'm marking this as resolved/no change required because the required function is present in the code.

For help about how to customize the function, please refer to:
http://www.mantisbt.org/forums

Issue History

Date Modified Username Field Change
2004-08-11 03:08 jwolfgarten New Issue
2004-08-11 03:29 jlatour Status new => acknowledged
2004-08-11 03:29 jlatour Relationship added related to 0004268
2004-08-11 03:30 jlatour Relationship added child of 0004181
2004-08-11 03:31 jlatour Relationship added related to 0004306
2004-08-11 03:41 vboctor Note Added: 0006928
2004-08-11 03:41 vboctor Status acknowledged => feedback
2004-08-11 03:48 jwolfgarten Note Added: 0006929
2004-08-11 03:56 vboctor Note Added: 0006931
2004-08-11 04:23 jwolfgarten Note Added: 0006933
2004-08-11 05:56 thraxisp Note Added: 0006937
2004-08-11 06:13 jwolfgarten Note Added: 0006938
2004-08-11 07:00 DGtlRift Note Added: 0006939
2004-08-11 07:01 DGtlRift Note Edited: 0006939
2004-08-11 07:02 DGtlRift Note Edited: 0006939
2004-10-04 08:05 vboctor Status feedback => new
2004-10-04 08:05 vboctor Category bugtracker => change log
2004-11-23 19:56 Matt_wc Note Added: 0008419
2008-04-22 04:58 giallu Status new => resolved
2008-04-22 04:58 giallu Resolution open => no change required
2008-04-22 04:58 giallu Assigned To => giallu
2008-04-22 04:58 giallu Note Added: 0017652
2008-07-31 17:39 giallu Status @0@ => closed