View Issue Details

IDProjectCategoryView StatusLast Update
0004484mantisbtrelationshipspublic2004-11-06 06:24
Reportermattis000102 Assigned Tomasc  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Fixed in Version0.19.1 
Summary0004484: Show which project a related issue belongs to
Description

If you have several projects that is dependent upon each other it would be very helpful if you could see which project a related issue belongs to in the "Relationships" part of the view of the issue. This could either be added as a separate column or maybe shown before the summary in [], like the category column in "View Issues" when you have selected "All projects".

To lessen the "overhead" for people that have few projects, it would probably be a good idea to only show this for issues that belong to another project than the issue that is being viewed.

TagsNo tags attached.

Activities

2004-09-06 02:27

 

masc

masc

2004-09-06 10:00

reporter   ~0007458

I agree we have to show the project name in case of relationship with bugs belonging to other projects.
Let me know if I have to proceed with the patch

vboctor

vboctor

2004-09-06 16:32

manager   ~0007461

I agree with displaying the project name (if different fromt the current issue's project). However, I think it should be displayed before rather than after the summary.

mattis000102

mattis000102

2004-09-07 05:07

reporter   ~0007470

I agree that it would probably look better if it was displayed before the summary. It was just easier to fake it after. Another idea would be to show it after the issue number. Feels like it would be clearer to have it there, it could get "lost" before the summary.

stevemagruder

stevemagruder

2004-09-25 14:48

reporter   ~0007744

Last edited: 2004-09-27 10:44

It would also be helpful to see the category of each issue in the relationship list. And this is helpful even when all related issues are in the same project.

Note: This would be OK as a configuration option.

Please advise if I should log this as a separate issue.

edited on: 09-27-04 10:44

grangeway

grangeway

2004-10-05 16:11

reporter   ~0007919

Patch from Masc For this issue and other issues committed:
Fix 0004506: When cloning a bug you should be able to set the relationship
Fix 0004484: Show which project a related issue belongs to
Fix 0004184: Related issues resolved email should be more informative
Fix 0004224: Can't resolve issue as duplicate of other with existing "related to" relationship

Related Changesets

MantisBT: master 3df7d2c5

2004-10-05 21:12:41

Paul Richards

Details Diff
Commit of Masc's Patches:
Fix 0004506: When cloning a bug you should be able to set the relationship
Fix 0004484: Show which project a related issue belongs to
Fix 0004184: Related issues resolved email should be more informative
Fix 0004224: Can't resolve issue as duplicate of other with existing "related to" relationship

git-svn-id: http://mantisbt.svn.sourceforge.net/svnroot/mantisbt/trunk@3037 <a class="text" href="/?p=mantisbt.git;a=object;h=f5dc347c">f5dc347c</a>-c33d-0410-90a0-b07cc1902cb9
Affected Issues
0004184, 0004224, 0004484, 0004506
mod - core/relationship_api.php Diff File
mod - core/email_api.php Diff File
mod - bug_relationship_delete.php Diff File
mod - lang/strings_italian.txt Diff File
mod - bug_report_page.php Diff File
mod - core/bug_api.php Diff File
mod - bug_relationship_add.php Diff File
mod - core/constant_inc.php Diff File
mod - bug_report.php Diff File
mod - bug_report_advanced_page.php Diff File
mod - core/history_api.php Diff File
mod - lang/strings_english.txt Diff File

Issue History

Date Modified Username Field Change
2004-09-06 02:27 mattis000102 New Issue
2004-09-06 02:27 mattis000102 File Added: Faked_relationsships_w_projects.PNG
2004-09-06 10:00 masc Note Added: 0007458
2004-09-06 16:32 vboctor Note Added: 0007461
2004-09-06 16:32 vboctor Status new => acknowledged
2004-09-07 00:26 masc Assigned To => masc
2004-09-07 05:07 mattis000102 Note Added: 0007470
2004-09-25 14:48 stevemagruder Note Added: 0007744
2004-09-27 10:44 stevemagruder Note Edited: 0007744
2004-10-05 16:11 grangeway Status acknowledged => resolved
2004-10-05 16:11 grangeway Fixed in Version => 0.19.1
2004-10-05 16:11 grangeway Resolution open => fixed
2004-10-05 16:11 grangeway Note Added: 0007919
2004-11-06 06:24 vboctor Status resolved => closed
2008-10-21 13:05 Changeset attached master-1.1.x 268ec56c =>
2008-11-11 08:39 Changeset attached master 3df7d2c5 =>
2008-11-11 08:53 Changeset attached master 3df7d2c5 =>