View Issue Details

IDProjectCategoryView StatusLast Update
0004491mantisbtrelationshipspublic2008-04-19 04:10
Reporterpdugas Assigned Tovboctor  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.19.0rc1 
Fixed in Version1.2.0a1 
Summary0004491: Deleting duplicate relationshilp left value in 'duplicate_id' field
Description

Had an issue that didn't show up in the ChangeLog page and figured out it had a non-zero value in the "duplicate_id" field. Perhaps the issue in question was marked a duplicate in an older version, not sure, but the "duplicate" relationship was deleted. Should the relationship_delete*() routines make sure the field is cleared when removing "duplicate" relathinships?

TagsNo tags attached.

Relationships

related to 0005114 acknowledged duplicate_id in mantis_bug_table should be deprecated and eventually removed 
related to 0004882 closeddregad Former duplicate of deleted entry not in Change-log 

Activities

jleuzinger

jleuzinger

2004-09-07 09:18

reporter   ~0007472

In my opinion is the field 'duplicate_id' no longer necessary and should be removed to prevent inconsistency with the bug_relationship_table.
A second problem is that duplicate_id > 0 prevents a bug from be displayed in the ChangeLog

masc

masc

2004-09-08 08:15

reporter   ~0007485

The problem is due to the mixing of duplicate relationships and duplicate_id field in the same database.

I guess we have to decide what to do. Do we have to maintain both the methods, or we can move to a unique solution based on just relationship (so removing every reference to the duplicate_id field)?

TomR

TomR

2004-09-08 08:33

reporter   ~0007486

I would like a unique solution based on relationship.

vboctor

vboctor

2004-09-08 08:58

manager   ~0007488

I think we should do the following:

  • Drop $g_enable_relationship from config_defaults_inc.php.
  • Mark $g_enable_relationship as obsolete in core/obsolete.php.
  • Drop the duplicate_id field by adding an database upgrade step.
vboctor

vboctor

2008-03-14 01:45

manager   ~0017336

  1. Removed enable_relationships configuration option.
  2. Removed duplicate_id from view, update, report pages.
  3. Removed duplicate_id for View Issues, CSV, Excel, Print Issues, etc.
  4. Kept duplicate_id in the database.
  5. Kept duplicate_id in the language files to be used to display old history entries.
  6. Kept old history entries.
  7. Kept the duplicate_id field in the schema.
  8. Kept the duplicate_id in the resolve page as a shortcut for setting duplicate relationships.
  9. Always remove duplicate id field from list of fields to be exported or viewed.

In Mantis 1.3, we can remove the duplicate_id field from the schema, remove associated history entries and remove it from language files. I just want to make sure we don't delete data for users that they may depend on it from ways I haven't considered.

Fixed by svn: Revision: 5110
http://mantisbt.svn.sourceforge.net/mantisbt/?rev=5110&view=rev

Issue History

Date Modified Username Field Change
2004-09-06 09:02 pdugas New Issue
2004-09-07 09:18 jleuzinger Note Added: 0007472
2004-09-08 08:15 masc Note Added: 0007485
2004-09-08 08:33 TomR Note Added: 0007486
2004-09-08 08:58 vboctor Note Added: 0007488
2004-09-08 17:08 vboctor Status new => acknowledged
2007-07-17 06:59 giallu Relationship added related to 0004882
2007-07-22 16:40 giallu Relationship added related to 0005114
2008-03-14 01:45 vboctor Status acknowledged => resolved
2008-03-14 01:45 vboctor Fixed in Version => 1.2.0
2008-03-14 01:45 vboctor Resolution open => fixed
2008-03-14 01:45 vboctor Assigned To => vboctor
2008-03-14 01:45 vboctor Note Added: 0017336
2008-04-19 04:10 vboctor Status resolved => closed