View Issue Details

IDProjectCategoryView StatusLast Update
0004781mantisbtbugtrackerpublic2013-02-16 18:58
Reporterpl Assigned Todregad  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
Product Version0.19.0 
Summary0004781: [Send Reminder] from adress in mail
Description

The 'from adress' in the mail is always the one written down in the configuration file. But I think for sending reminders it should be better if it is possible to make the 'from adress' the same as the email adress from the user who sends the reminder.
I say to make it possible, not to make it obligated. So this option can be activated simply by setting an environment variable in the config_inc.php file.
I already wrote the code which can do this; look at the additional information.

Additional Information

This is a diff between the 0.19.0 code and my code.
527c527
< function email_send( $p_recipient, $p_subject, $p_message, $p_header='', $p_category='', $p_exit_on_error=true ,$p_sender_email='') {

  function email_send( $p_recipient, $p_subject, $p_message, $p_header='', $p_category='', $p_exit_on_error=true ) {

594,597d593
< if(!empty($p_sender_email))
< {
< $mail->From = $p_sender_email;
< }
748a745

750,756c747
< if(config_is_set( 'bug_reminder_from_online_user' ) && ON == config_get( 'bug_reminder_from_online_user' ) ) {
< email_send( $t_email, $t_subject, $t_contents,'','',true,current_user_get_field( 'email' ));
< }
< else
< {
< email_send( $t_email, $t_subject, $t_contents,'','',true,'');
< }

                          email_send( $t_email, $t_subject, $t_contents );
TagsNo tags attached.

Relationships

duplicate of 0010371 confirmed Added ability for reminders to come from the user who sent them rather than the from_email 

Activities

masc

masc

2004-10-27 06:29

reporter   ~0008182

I share this opinion.

MattB

MattB

2005-07-19 14:35

reporter   ~0010876

Me too - would be very useful to have the remdiners come from the person sending it rather than the Mantis address.

Additionally, it would be useful to prepend the subject with "REMINDER: " which stands out more than a normal Mantis e-mail.

Issue History

Date Modified Username Field Change
2004-10-26 10:35 pl New Issue
2004-10-27 06:29 masc Note Added: 0008182
2005-07-19 14:35 MattB Note Added: 0010876
2013-02-07 04:30 dregad Relationship added duplicate of 0010371
2013-02-07 04:30 dregad Status new => resolved
2013-02-07 04:30 dregad Resolution open => duplicate
2013-02-07 04:30 dregad Assigned To => dregad
2013-02-16 18:58 atrol Status resolved => closed