View Issue Details

IDProjectCategoryView StatusLast Update
0004888mantisbtfeaturepublic2007-12-20 01:37
Reportercwright Assigned Togiallu  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version0.19.1 
Summary0004888: Attach a time amount to an issue
Description

I use mantis to handle issues/bugs for an application I develop for a client. The client creates issues in mantis and gives them a priority. I take the issues, work on them and resolve/close the issue once it is fixed. Currently, I have a custom field named "Hours Worked" where I log time that I spent on the issue. This is not working as well as I would like because the custom field does not have a date/time associated with it, so when I work on an issue multiple times, it can span multiple months and billing cycles.

My feature request is that it would be nice if along there could be a way to attach an amount of time worked (along with /when/ it was logged) to issues, and then be able to report on it. So I could ask mantis "how much time did I work for customer ABC during November 2004."

Does this sound like a reasonable request?

Thanks for your time, and for all that Mantis already is.

Cory Wright

TagsNo tags attached.

Relationships

duplicate of 0004428 closeddavidnewcomb Time Tracking 

Activities

cwright

cwright

2005-03-28 23:31

reporter   ~0009674

Are there any plans for this feature? I'd be willing to sponsor something to get this into mantis. I need an easy way to report the amount of time I have worked for clients in the past month. Currently I have a custom field but it takes me a lot of time to go back through all issues that have been updated during the last month and gather the hours to produce a bill.

It would be great to be able to attach an amount of time when adding a bugnote or when creating the issue.

Thanks,

Cory

giallu

giallu

2007-10-30 06:45

reporter   ~0016029

This is the "Time Tracking" feature and it was introduced in 1.1.0a3

Issue History

Date Modified Username Field Change
2004-11-20 11:08 cwright New Issue
2005-03-28 23:31 cwright Note Added: 0009674
2007-10-30 06:45 giallu Relationship added duplicate of 0004428
2007-10-30 06:45 giallu Duplicate ID 0 => 4428
2007-10-30 06:45 giallu Status new => resolved
2007-10-30 06:45 giallu Resolution open => duplicate
2007-10-30 06:45 giallu Assigned To => giallu
2007-10-30 06:45 giallu Note Added: 0016029
2007-12-20 01:37 vboctor Status resolved => closed