View Issue Details

IDProjectCategoryView StatusLast Update
0004915mantisbtbugtrackerpublic2004-12-11 03:01
Reporterpacketeer Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version0.19.1 
Summary0004915: Workflow checking is not implemented on Reopen (where status is changed back to NEW_, or whatever set in $g_bug_reopen_status)
Description

A fix can be implemented in bug_update.php, by checking workflow before calling bug_reopen as follows:

#fix - check workflow
if ( FALSE == bug_check_workflow($t_old_bug_status, config_get( 'bug_reopen_status' ) )) {
       trigger_error( lang_get( 'bug_actiongroup_status' ), ERROR );
 }
#end fix
bug_reopen( $f_bug_id, $f_bugnote_text );
etc... 
TagsNo tags attached.

Activities

thraxisp

thraxisp

2004-11-30 08:59

reporter   ~0008457

The re-open status change is allowed over and above the workflow. It has it's own separate access level ($g_reopen_bug_threshold) to control it. This is also complicated by the optional ability of a reporter to re-open and close their own bugs.

I think that this works properly now.

packeteer

packeteer

2004-11-30 17:56

reporter   ~0008462

Last edited: 2004-11-30 19:01

will look at the issue again, looks like it is actually a bug :)

maybe my wording was poor

Issue History

Date Modified Username Field Change
2004-11-28 20:58 packeteer New Issue
2004-11-30 08:59 thraxisp Note Added: 0008457
2004-11-30 08:59 thraxisp Status new => feedback
2004-11-30 17:56 packeteer Note Added: 0008462
2004-11-30 19:01 packeteer Note Edited: 0008462
2004-12-01 11:11 thraxisp Status feedback => resolved
2004-12-01 11:11 thraxisp Resolution open => won't fix
2004-12-01 11:11 thraxisp Assigned To => thraxisp
2004-12-01 11:11 thraxisp Assigned To thraxisp =>
2004-12-11 03:01 vboctor Status resolved => closed