View Issue Details

IDProjectCategoryView StatusLast Update
0005055mantisbtcustom fieldspublic2014-10-24 06:47
Reporterstevemagruder Assigned Tograngeway  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionwon't fix 
Product Version0.19.2 
Summary0005055: Need a way to sum custom number/float fields
Description

I added "Est. Time (hrs.)" and "Actual Time (hrs.)" custom float fields, and applied them to a specific project that also contains versions.

I would like to be able to sum these fields across the project or across a version of the project.

Perhaps a selectable feature of a custom field that's a number or float could be "Show sum in Summary". In the summary, it would break the sums down by version and also show the total for the project.

TagsNo tags attached.

Activities

stevemagruder

stevemagruder

2004-12-29 01:19

reporter   ~0008822

This could also apply to custom time fields (counting time), if they are implemented, per 0005056.

stevemagruder

stevemagruder

2005-01-05 12:51

reporter   ~0008849

At first, I could imagine a box in the Summary that lists the summable custom fields and their associated sums for the project. Also, once there is an ability to filter the summary based on versions (which I believe is another feature request somewhere), that would apply to the sums as well.

stevemagruder

stevemagruder

2005-04-29 09:18

reporter   ~0009961

Might this make it into Version 1.0? This would be an awesome feature. And there seems to be demand for using a field like this to sum up project times and costs.

ralfiii

ralfiii

2005-06-14 03:49

reporter   ~0010502

I've created a patch to 1.0.0a2 for adding

  • Original Estimation
  • Current Estimation
  • Elapsed time
    and a calculated
  • Remaining time

It also displays sums (e.g. the summed remaining time of child tasks)

I've attached the patch and 2 screenshots to issue 0004428

Maybe this is something for you.

stevemagruder

stevemagruder

2005-06-14 15:50

reporter   ~0010522

I'd like to see something more generic, but I appreciate your effort at any rate. I may get a chance to look at it soon.

grangeway

grangeway

2014-10-10 18:14

reporter   ~0041543

Resvoling as 'wont fix' for now, unless you want to reopen and suggest how this could be sensible implemented, or even what exactly would need to be done.

This strikes me as a request to allow summary of a custom field that is an integer against other meta data e.g. version

Given that you might want a min/avg/max/mean/median etc and against resolution/severity/version etc etc - I'm actually not clear where you'd want results displayed, or what results would even need to be corrected.

Since 0.19.2 when this was originally raised, we've added plugins to the core - so this strikes me as something that would now be better implemented for a specific purpose within a plugin.

Equally, if you feel there's some simple things we could actually look at implementing, please reopen this issue and add some bugnotes with specific ideas that could be constructed into a work item to make a change.

Issue History

Date Modified Username Field Change
2004-12-29 00:25 stevemagruder New Issue
2004-12-29 01:19 stevemagruder Note Added: 0008822
2005-01-05 12:51 stevemagruder Note Added: 0008849
2005-04-29 09:18 stevemagruder Note Added: 0009961
2005-06-14 03:49 ralfiii Note Added: 0010502
2005-06-14 15:50 stevemagruder Note Added: 0010522
2014-10-10 18:14 grangeway Note Added: 0041543
2014-10-10 18:14 grangeway Status new => resolved
2014-10-10 18:14 grangeway Resolution open => won't fix
2014-10-10 18:14 grangeway Assigned To => grangeway
2014-10-24 06:47 atrol Status resolved => closed