View Issue Details

IDProjectCategoryView StatusLast Update
0005109mantisbtadministrationpublic2010-04-23 23:23
Reporterguideweb Assigned Todhx  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Summary0005109: BugTracker can have (0) administrator !
Description

Bug tracker can have (0) user with administrator access level!

When we downgrade 'administrator' user, i think we should check if other user with 'administrator' exist. If not, dont allow operation

Steps To Reproduce
  1. Manage
  2. Manage Users
  3. administrator
  4. Unselect Protected:
  5. Update user
  6. Change access level to anything
TagsNo tags attached.

Relationships

duplicate of 0010687 closeddhx Administrators shouldn't be allowed to delete their own account 

Activities

dhx

dhx

2010-01-16 23:52

reporter   ~0024177

This was fixed in 0010687

Issue History

Date Modified Username Field Change
2005-01-12 15:33 guideweb New Issue
2005-01-12 18:45 vboctor Status new => acknowledged
2010-01-16 23:51 dhx Relationship added duplicate of 0010687
2010-01-16 23:52 dhx Note Added: 0024177
2010-01-16 23:52 dhx Status acknowledged => resolved
2010-01-16 23:52 dhx Resolution open => duplicate
2010-01-16 23:52 dhx Assigned To => dhx
2010-04-23 23:23 dhx Status resolved => closed