View Issue Details

IDProjectCategoryView StatusLast Update
0005896mantisbtadministrationpublic2019-08-15 09:15
Reporternkolev Assigned Tovboctor  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version1.0.0a3 
Target Version1.2.0a3Fixed in Version1.2.0a3 
Summary0005896: Allow developers to let other users monitor issues
Description

It would be nice if a manager can add a user to the issue monitoring list. In addition to the showing the name of the people monitoring the issue, it would be nice to show their role (reporter, developer, etc.)

The reason for this feature request is that sometime there's a specific QA person assigned to test an issue and it's nice to be able to see who's that QA when looking into an issue. Of course, it would be much better to allow multiple people to be assigned to an issue, but I think this is too much of a change.

TagsNo tags attached.

Relationships

related to 0026002 assignedcproensa "Email on monitoring" not configurable in manage_config_email_page 

Activities

thraxisp

thraxisp

2005-07-08 06:31

reporter   ~0010692

There is a backdoor way of accomplishing this. With the default configuration, sending a reminder to someone adds them to the monitor list.

michield

michield

2005-07-15 22:01

reporter   ~0010800

I second this one, and I think it's nice to do without sending the reminder.

dhaun

dhaun

2008-10-11 17:12

reporter   ~0019536

I was looking for this functionality since I'm used to it from Bugzilla (where you can add people to CC: at any time). In the end, sending a reminder does exactly the same - but it's not really intuitive or easy to find, IMO.

If it's considered an official feature that sending a reminder to someone adds them to the monitoring list, then it would be nice if the Monitoring field also had a link (for Admins only) to the reminders dialog.

vboctor

vboctor

2008-11-20 03:00

manager   ~0019951

Implemented with default access level = DEVELOPER. Hence, changed the summary of the issue.

Related Changesets

MantisBT: master 514ba802

2008-11-20 07:59:42

vboctor

Details Diff
Fixed 0005896: Allow developers to let other users monitor issues. Affected Issues
0005896
mod - lang/strings_english.txt Diff File
mod - core/email_api.php Diff File
mod - bug_monitor_list_view_inc.php Diff File
mod - bug_monitor.php Diff File
mod - core/bug_api.php Diff File
mod - config_defaults_inc.php Diff File
mod - docbook/adminguide/en/configuration.sgml Diff File

Issue History

Date Modified Username Field Change
2005-07-07 14:09 nkolev New Issue
2005-07-07 14:12 nkolev Sponsorship Added nkolev: US$ 5
2005-07-07 14:12 nkolev Sponsorship Total 0 => 5
2005-07-08 06:31 thraxisp Note Added: 0010692
2005-07-15 22:01 michield Note Added: 0010800
2008-10-11 17:12 dhaun Note Added: 0019536
2008-11-20 02:56 vboctor Status new => assigned
2008-11-20 02:56 vboctor Assigned To => vboctor
2008-11-20 03:00 vboctor Note Added: 0019951
2008-11-20 03:00 vboctor Status assigned => resolved
2008-11-20 03:00 vboctor Resolution open => fixed
2008-11-20 03:00 vboctor Fixed in Version => 1.2.2
2008-11-20 03:00 vboctor Target Version => 1.2.2
2008-11-20 03:00 vboctor Summary Allow managers to let other users monitor issues => Allow developers to let other users monitor issues
2008-12-30 22:00 jreese Fixed in Version 1.2.2 => 1.2.0a3
2008-12-30 22:06 jreese Target Version 1.2.2 => 1.2.0a3
2009-01-15 11:25 jreese Status resolved => closed
2019-08-15 09:10 dregad Relationship added related to 0026002
2019-08-15 09:15 dregad Changeset attached => MantisBT master 514ba802