View Issue Details

IDProjectCategoryView StatusLast Update
0006017mantisbtchange logpublic2008-07-24 16:51
ReporterMark Ingram Assigned Togiallu  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionduplicate 
Product Version1.0.0rc1 
Summary0006017: Filter change log by specific versions
Description

The changelog can grow into quite an unmanageable list as it lists all the changes between every version. Would be good if we could look at a specific few versions.

TagsNo tags attached.

Relationships

duplicate of 0008334 acknowledged Paginate/Limit Changelog 
related to 0006005 closedgiallu Ability to request a version on changelog 

Activities

vboctor

vboctor

2005-07-26 18:35

manager   ~0010974

There are two ways to implement this:

  • "Show in Changelog" flag in version properties.
  • A way to filter the versions.

I think the first approach is easier to implement, simpler to use and will do the job.

nuclearspike

nuclearspike

2005-07-27 15:49

reporter   ~0010990

Victor,

I disagree that the first one is easier to use. It means that to ever have versions no longer display, you have to go and edit that version information. We have maybe 50 versions or more of change log. Part of the usage of this is that it should be able to be switched on and off easily. I only want to see the last 10 releases because that's where the interesting issues show up. But, that doesn't mean that under certain conditions that I wouldn't want to view all, or possibly the last 20 versions.

I think having a drop down of either "All, Last 5, Last 10, Last 25, Last 50" or by date "All, Last 1 month, Last 3 months, Last 6 months". Just store the selection as a cookie. Having it show by the last x versions is probably easier, just do a LIMIT sql statement on the query that pulls out the version info.

Having a "Show in Changelog" flag would be both tedious to keep up to date as new releases came out, plus it limits you so that once it's not shown, you aren't able to see that change log entry anymore. Let's say I get an email from a customer who is finally getting their software up to a rather old (but proven very stable) release. It's been checked to no longer show up, rather than just changing a drop down and having it requery with a wider range, I have to go to Manage, Projects, find the version, Edit, Change to Show, Save, Go back to Change Log, get the data, and then repeat the first part to hide it again.

Mark Ingram

Mark Ingram

2005-07-28 04:37

reporter   ~0010997

I agree with nuclearspike, we're in a similar position with around 50ish versions, a filter would be much easier for the end user.

jswanson

jswanson

2005-07-28 14:07

reporter   ~0011007

I also have to agree with nuclearspike.
Changelog Usage 1: Grab text from latest version to copy/paste or otherwise use to document
Changelog Usage 2: Quick scan of recent releases (month or two) to review Dates and Version Description text in Changelog
Changelog Usage 3: Review entire log

Since the interest in version changes is primarily a function of time, Victor's first option would mean having to go back to each version I'm no longer interested and manually unchecking the flag. Tedious.

david_s_nl

david_s_nl

2005-10-25 15:34

reporter   ~0011534

Yes, the ability to show only the changes of 1 (or some) particular version would come in very handy !!

giallu

giallu

2008-04-22 04:50

reporter   ~0017651

I think this is the same issue as 0008334.

Feel free to add your comments/suggestions there

Issue History

Date Modified Username Field Change
2005-07-26 11:09 Mark Ingram New Issue
2005-07-26 18:35 vboctor Note Added: 0010974
2005-07-26 18:35 vboctor Category filters => change log
2005-07-27 14:31 thraxisp Relationship added related to 0006005
2005-07-27 15:49 nuclearspike Note Added: 0010990
2005-07-28 04:37 Mark Ingram Note Added: 0010997
2005-07-28 14:07 jswanson Note Added: 0011007
2005-10-25 15:34 david_s_nl Note Added: 0011534
2008-04-22 04:50 giallu Relationship added duplicate of 0008334
2008-04-22 04:50 giallu Status new => resolved
2008-04-22 04:50 giallu Resolution open => duplicate
2008-04-22 04:50 giallu Assigned To => giallu
2008-04-22 04:50 giallu Note Added: 0017651
2008-07-24 16:51 vboctor Status @0@ => closed