View Issue Details

IDProjectCategoryView StatusLast Update
0006480mantisbtcustomizationpublic2013-04-10 10:05
Reportermirko_fit Assigned Todregad  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
Product Version1.0.0rc2 
Summary0006480: custom "My View" page for each user or access level
Description

The team leaders in my company requested a customizable my view.

The best implementation would be a customizable My View for each user including global MyViews that can be configured by the managers or admins.

Another idea is to add different MyViews for developers, managers and so on.

For example:
Viewers see "Monitored by me" and "Resolved"
Reporters see "Monitored by me", "Resolved" and "Reported by me".
Developers only see "assigned to me","Monitored by me" and "Reported by me"
Managers see all blocks as well as admins do.

Furthermore there could be some specific filters. If the MyView would be customizable for each user, it would be possible to add custom Blocks on the MyView page, such as "Assigned to me ordered my priority" for a developer or "assigned to my subordinates" for a manager.

Tagsredesign

Relationships

duplicate of 0007840 acknowledged Customizable 'my view' page 

Activities

chillax

chillax

2006-04-21 19:06

developer   ~0012666

Last edited: 2006-04-21 19:16

I think something like this would be useful. Although I was thinking more of turning the My View page into a widget-based page such that each user could choose to add or remove certain widgets, arrange them, customize how many items to display, etc. Would either need to store customization info in the database or a cookie, would prefer the database option.

The title bar for each widget might look something like this:
Widget Title--Dropdown for display(1,5,10,20,etc)--[Roll Up Icon]

Maybe allowing users to save filters and linking their list of available widgets to their saved filters.

mirko_fit

mirko_fit

2006-04-22 05:18

reporter   ~0012681

Your idea sounds good.
Such changes should come with an option to save global MyViews to allow admins to place MyView-templates, so the users don't need to customize the MyView themselves.

daryn

daryn

2010-09-28 20:24

reporter   ~0026896

A similar feature branch is near complete at http://github.com/daryn/mantisbt/tree/save-filter.

psy5ive

psy5ive

2012-10-16 15:46

reporter   ~0033235

I found a solution if this helps anyone else searching for it.

in my_view_page.php,

find:

$t_boxes = config_get( 'my_view_boxes' );
asort ($t_boxes);
reset ($t_boxes);

and replace with (for example):

$t_boxes = config_get( 'my_view_boxes' );
if ( user_get_access_level( $t_current_user_id, helper_get_current_project() ) == REPORTER ) {
$t_boxes = array ( 'assigned' => '0',
'unassigned' => '3',
'reported' => '1',
'resolved' => '2',
'recent_mod' => '4',
'monitored' => '5',
'feedback' => '0',
'verify' => '0' );
}
if ( user_get_access_level( $t_current_user_id, helper_get_current_project() ) == MANAGER ) {
$t_boxes = array ( 'assigned' => '1',
'unassigned' => '4',
'reported' => '5',
'resolved' => '6',
'recent_mod' => '3',
'monitored' => '2',
'feedback' => '0',
'verify' => '0' );
}
if ( user_get_access_level( $t_current_user_id, helper_get_current_project() ) == ADMINISTRATOR )
{
$t_boxes = array ( 'assigned' => '1',
'unassigned' => '4',
'reported' => '2',
'resolved' => '3',
'recent_mod' => '5',
'monitored' => '6',
'feedback' => '0',
'verify' => '0' );
}
asort ($t_boxes);
reset ($t_boxes);

dregad

dregad

2012-10-17 06:35

developer   ~0033249

Thanks for your proposal; this issue is a duplicate of 0007840, please follow up there.

Issue History

Date Modified Username Field Change
2005-12-09 05:00 mirko_fit New Issue
2006-04-21 19:06 chillax Note Added: 0012666
2006-04-21 19:10 chillax Note Edited: 0012666
2006-04-21 19:16 chillax Note Edited: 0012666
2006-04-22 05:18 mirko_fit Note Added: 0012681
2010-09-28 20:24 daryn Note Added: 0026896
2010-09-28 20:25 daryn Tag Attached: redesign
2012-10-16 15:46 psy5ive Note Added: 0033235
2012-10-17 06:35 dregad Note Added: 0033249
2012-10-17 06:35 dregad Relationship added duplicate of 0007840
2012-10-17 06:35 dregad Status new => resolved
2012-10-17 06:35 dregad Resolution open => duplicate
2012-10-17 06:35 dregad Assigned To => dregad
2012-10-27 09:21 atrol Status resolved => closed