View Issue Details

IDProjectCategoryView StatusLast Update
0007669mantisbtlocalizationpublic2009-06-11 06:33
ReporterstsivinAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformPHP 4.3.11, MySQL 4.1.14OSWindowsOS Version XP
Product Version1.0.6 
Target VersionFixed in Version 
Summary0007669: [all lang] Email field padding is not working correctly when using multibyte encodings
Description

If I select russian_utf8 as my preferred language, email reports are not padded evenly, example:

<pre>Воспроизводимость: всегда
Серьезность: нововведение
Приоритет: неотложный
Состояние: назначен
======================================================================
Создан: 12-16-2006 06:50 Russian Standard Time
Изменен: 12-16-2006 09:46 Russian Standard Time
====================================================================== </pre>

I suspect that str_pad function, which is used in email_api.php, is not compatible with multi-byte encodings such as UTF-8.

TagsNo tags attached.

Relationships

duplicate of 0008572 closedjreese multibyte str pad problem 

Activities

stsivin

stsivin

2006-12-18 12:34

reporter   ~0013843

The example that I posted in this ticket is not displayed correctly. Simply put: attribute values are not left aligned.

siebrand

siebrand

2009-06-11 06:26

developer   ~0022079

Confirmed. No idea how to get this resolved, though. Patches, please!

siebrand

siebrand

2009-06-11 06:33

developer   ~0022081

duplicate of 0008572

Issue History

Date Modified Username Field Change
2006-12-18 12:31 stsivin New Issue
2006-12-18 12:34 stsivin Note Added: 0013843
2006-12-18 14:01 ryandesign Description Updated
2006-12-30 05:47 achumakov Summary Email field padding is not working correctly when using russian_utf8 => [all lang] Email field padding is not working correctly when using multibyte encodings
2009-06-11 06:26 siebrand Note Added: 0022079
2009-06-11 06:26 siebrand Status new => confirmed
2009-06-11 06:32 siebrand Relationship added duplicate of 0008572
2009-06-11 06:33 siebrand Note Added: 0022081
2009-06-11 06:33 siebrand Status confirmed => closed
2009-06-11 06:33 siebrand Resolution open => duplicate